GL-MT3000 can't acquire network from bridged modem


I have cable internet with Comcast and use a Motorola MG7700 modem to connect to internet.

Since I have multiple routers including my recently bought Beryl AX router, I decided to put my Motorola cable modem in bridge mode to reduce one layer of network routing.

I tested my Motorola modem’s internet connection after putting it in bridge mode by connecting my MacBook to the modem using the Ethernet cable, Mac was able to acquire network address (IP/DNS/…) and get access to the internet.

So far so good, but when I connected the same ethernet cable to Beryl AX’s WAN port, the router was not able to connect to the internet as if it was not able to acquire network address from DHCP server (but I am just guessing here).

I would appreciate if anybody can help me troubleshoot and fix this?

GL GUI → Internet → Ethernet should show the Protocol, IP Address, Gateway, DNS Server being pulled fr Upstream.

… but failing that you’re going to want to get unfettered access to the logs via SSH (default IP See attached:

1 Like

You wouldn’t believe what worked!

I changed my router’s MAC address manually and replaced it with my MacBook’s MAC address so now it works; got the idea from ChatGPT!

It might be something unique to your ISP, then. That’s also the first method you should try when setting up the device on a hotspot like in a hotel, coffee shop after you authenticate to their portal.

This is a typical problem. Let me repost here:

Problem: Router cannot get IP address (DHCP or PPPoE) when you put the cable from ISP to the WAN Interface.

Cause: The ISP modem has lock the mac address of your old router. It will not accept new router.

Solution: Here are the solutions. Either one should work.

  1. Just clone your old router’s mac addresss to the new router and it will work immediatelly.
  2. The modem needs a reboot or reset to accept new router. Reboot the modem and try. If it does not work immediatelly, turn the modem off for 30 minutes then turn it on. Then have a try. You can just leave the router and modem connected although the router cannot get IP. Just go to a lunch or sleep. After you come back, it is likely to get IP already.
  3. Call you ISP and tell me you need to change router and ask them to reset the modem.
1 Like

It might be worth getting that info into the v 4.x docs: