GL-MT3000 LAN to WAN Traffic Blocked

Device: GL-MT3000
Firmware: currently 4.5.0, but problem existed with 4.4.6
Topology: Wireless Router —> GL-MT3000 (WAN) <—> GL-MT3000 (WLAN) <—MacBook Pro 13" 2020 and iPhone 14

logread.tar (229.5 KB)

My GL-MT3000 has stopped working. I previously had it working fine in two locations in repeater mode. I returned to one location and hoped to just start using it as I had last time, but it wouldn’t provide a connection between WLAN clients and Internet.

The Internet side works fine because it was able to automatically check and download firmware 4.5.0, but no connection can be made between the WLAN and Internet.

I’d like to learn how to troubleshoot with GL iNet devices so I haven’t simply done a factory reset yet. Hopefully, there’s a way on the forum to solve it or show me what stupid thing I did.

Can you connect to the Internet if you use a cable connection?

Unfortunately not. I have connected Ethernet with the same error and I’ve tethered my iPhone and again the same error.

The WAN says all good to go in each case so we have a connection, but LAN can’t get through.

I tried the Ethernet LAN connection today and that still doesn’t get a connection through WAN.

Could you please list the IP networks you are using on each device?

When I am at home where I am more able to test LAN is 192.168.8.x
WAN is 192.168.1.x

If I am working remote I’ll update with other WAN networks. I can recall that I had a 10.x.x.x and a 172.x.x.x private network in two locations last week.

I am more confused about this one. Each of these devices must use a unique IP address space, is that the case?

Maybe you can draw an diagram: How to get support quickly

@admon Does this help? Happy to add more detail, but this shows the real use-case I have. All other set-ups where there is no route from WLAN to WWAN are purely additional failures discussed when trying to troubleshoot my real use-case, i.e. Wired LAN to WWAN, WLAN to Wired LAN and WLAN to tethered iPhone WAN also all fail, but are not the use-case I want working.

1 Like

That’s the most wonderful and realistic network diagram I ever saw! :+1: :smile:

Unfortunately, it doesn’t really help because the only thing I can say is: This should work out of the box. :frowning:


It did work for a week across different coffee shops and hotels and then the next time I turned it on it stopped.

I’ve noted down the configuration I had so I guess I’ll just do a factory reset and hope it comes back to life.

You could try this firmware as well: MT3000 Beryl AX Open Source WiFi driver firmware

Am I correct that this is an upgrade to the underlying Open WRT router software that the Beryl runs on?

Will this affect operation at all (apart from maybe fixing my problem) so all menu functions are the same?

I will try that before the hard reset. Is there a guide to doing the update anywhere?

Okay, I messed up and I’ve fixed it after a hunch. Thanks for trying to help.

I had the “Block Non-VPN traffic” option selected. I wasn’t using a VPN so didn’t see this as a problem because in my head it meant it only applied when using a VPN.

That was wrong, without a VPN nothing works including making local requests to the Captive server to get network access on a hotel or coffee shop WiFi network. Which, of course, you would have to do before you got a VPN established so it created a paradox. Can’t connect to network to establish VPN, but can’t establish VPN without connecting to network.