MT3000 Beryl AX Open Source WiFi driver firmware

System upgrade: From SDK-based OpenWrt-21.02 to fully open source OpenWrt-23.05.

7 Likes

You can upgrade it by WEB. It’s a beta version, So if you have any issue, please feel free to contact us :grinning:

2 Likes

version 23.05 of openwrt has some problems that were not resolved and they still released it, like the case of the MT6000 that came with 23.05 and has problems with wifi 2.4 which even in pure openwrt has the same problem, do you think it is valid and Is it a good idea to start porting to 23.05?

my opinion would be better if the MT6000 was made based on version 22.03 of Openwrt.

Yeah, we prepared this firmware for about 2 weeks, beside the WIFI 2.4G issue(Low throughput with old android phone ) we also have some issue need to be solved. The old firmware is based on 21.02 and MTK WIFI driver Which have some strange issue.
The WIFI 2.4G issue we have got some log and sent it to our supplier for further analysis, hope will have some good progress after the new year holiday.

1 Like

Ah cool,
but I have a friend who is also having serious problems with latency and high ping even on the 5ghz network.
This is on the MT6000 but the errors are the same, it is something related to the mediatek firmware that has problems.

@raphamotta

Ok just tested and it’s good, finally have a better wifi range.

Tested with 2,4ghz with my Huawei P30 Pro (2019) and the download speed is slower then firmware 4.5.0 (150Mb/s vs 231Mb/s). The latency is higher too. But it’s better than GL-MT6000 on 2,4ghz.

So it seems the 2.4ghz issue is also related with the openwrt firmware

1 Like

Where’s the flagship devices firmware, @alex_zheng ? I gotta Flint v1 & a Slate AX not 4 feet/122 cm away fr me… I didn’t buy the Beryl AX for a reason, 'ya know.

2 Likes

I will check with RD after the new year holiday. And Happy New Year to you.
Now we are working on the issue of MT6000 and MT3000, So the time may not so fast.

4 Likes

Thanks for doing so & the same to you, Alex… but it’s still another eleven days to New Year’s. :wink:

dragon

2 Likes

Sorry for the mistake, and thanks for the addition info about the New Year. I used to think January 1st was New Year’s Day for everyone. :rofl: :rofl:

1 Like

Oh, January 1st is for my side of the hemisphere… not that I’m not envious of a week’s worth of celebration, or anything. Do me a favor: just make sure the food is as good as the festivities. :slight_smile:

1 Like

my guess @bring.fringe18 - is that the delay in moving to to latest version of OpenWrt for Flint 1 / Slate AX is due to the hardware (CPU) support required (both of these use the Qualcomm IPQ6000 that are not currently supported per the OpenWrt hardware search website, whereas Beryl AX and Flint 2 use MediaTek CPUs respectively - which are supported).

Based on a few searches regarding IPQ6000 on latest OpenWrt in the forums - seems that it would take a significant effort to support and likely won’t be supported:

EDIT: there is some progress on AX1800 noted here - but it’s very much in active development still. Primary issue seems to be around the CPU clock(s). There’s links to dev builds in this thread if you’re interested in giving them a run…

1 Like

@solidus1983 is already building vanilla for IPQ6000.

Yep - i found that megathread a few hours later… still reading through it… :slight_smile: hopefully decent progress has been made.

1 Like

news about a new firmware for the mt3000 and mt6000 with the 2.4ghz correction?

I’m testing 4.5.5 for the MT6000 and everything is working as it should, except 2.4

No, 2.4Ghz issus is under working. We need more time to solve it.

I will upgrade, let’s see how it goes :grinning:

I’ve been testing it for hours, I absolutely love it, I can finally use the Samba server, it is slower now but it is way more stable, it was unusable before, too many drops and sometimes I wasn’t even able to transfer a large file, now it works like a charm, it seems hugely optimized, I even did some heavy speed tests on my normal network and on my VPN VLAN while transferring a 20GB file and it didn’t drop or got any error like it used to, tried it several times.

It also has a better range, more transmit power, it used to be 20dbm and now you can set it to 24dbm (on LuCi). It will be set to the maximum power once you upgrade though

Now I wonder if the V4.6 will have the QoS option later, so far a great first impression

1 Like

Qos is not on the function list of V4.6

It will come later I guess, I’d like to see an option to enable USB 2.0 mode so we can avoid the USB 3.0 interference.
This alpha 4.6 version seems to be working well, I’ve been testing
Do you have a list of each feature of the V4.6? I know it’s too early for it though