GL-MT3000 RDP disconnecting issues

Goodmorning fellows,

I have an issue, I create a vpn connection between my home vpn router which is running on a Asus GT-AX11000 and my GL.INET GL-MT3000.

After the RDP connection with one of the home computers is issued it disconnects randomly while this is not the case if the vpn connection was build with the windows client. The port on the GL.INET firewall (3389) is opened. I think it is a GL.INET router issue.

So thanks in advance for thinking with me,


Did you ask the same question on github? We are looking into this problem.

Thanks for the reaction, where and how to install the mtk wifi driver?



I did not ask the same question on github

I just installed the beta firmware release 2 and the problem seems to be solved. Now the connection remains for 1 hour already. So it seems to be a firmware issue

Update: It works flawless sins update to the newest Beta firmware no disconnections anymore…

1 Like

Using a 5Gwifi connection, I tried versions 4.2.0 and 4.2.1 and did not see this problem.