GL-MT3000 really really slow?

I just purchased a GL-MT3000 travel router. I turned it on and attached to its default wifi. I connected just fine. However, if I try to navigate to the default admin webpage, it is timing out all over the place and difficult to use. I tried just pinging the mgmt interface and I am getting response times all over the place but peaking well over 2 seconds. I’m assuming this explains why the webpage is so difficult to use?

I was able to navigate to the Upgrade tab and upgrade to the latest firmware. I re-connected but the behavior is the same.

Anyone else getting abysmal performance with this router? I was even able to connect to my captive portal network and share it through this router, but connecting through this has similar poor performance. I can’t imagine I am doing anything to cause this, did I just get a bum device?

If you ping your device, will it timeout as well?
Which network do you use and how does your network looks like?

All I did was turn the GL-MT3000 on and connect to the default wifi. Nothing extra configured. Default everything. I am physically inches from the router, my PC shows 100% wifi signal. I connect to wifi just fine. It dolls me out a DHCP IP address. At this point, I ping (the travel router’s default IP) and the response times are very very slow. My PC is not connected to anything else. If I connect my same PC to my regular local network, response times are great. The issue is just that this router is really really slow to respond.
Whatever I configure on the router seems to “work”, its just really slow and the interface is repeatedly timing out. I’m assuming it is due to this bad latency.
I have not tried ethernet yet as the machine I am connecting from only has wifi. My primary use for this travel router would be for it to host a wifi network so I figured that would be a good thing to test.

If I ping my local machine, it responds just fine. My network is as simple as it gets: GL-MT3000 hosting a wifi signal and my laptop is connected to it.

Obviously it is more complicated when I set it up in repeater mode and give it network access, but nothing changes on the “LAN” side connected to my laptop. The WAN side seems to work fine, but it doesn’t really matter if all LAN side packets are subject to seconds worth of latency.

You asked which network I use, I assume you mean 2.4 or 5Ghz wifi? So far, I have only tried 2.4 (as that is what my primary use is) but I will try the 5Ghz radio and see if that is any better…

I switched to the 5GHz radio and response times are down around 1ms (as I would expect). Some sort of interoperability problem with my Microsoft Surface laptop’s 2.4GHz radio? It works fine with everything else I connect it to.
I’ve factory reset the router, upgraded to the latest firmware, but I can’t seem to get anything but terrible latency on the 2.4GHz wifi LAN network.

Are there many other 2.4 GHz Wi-Fis around you?

There are some, but I am in a pretty rural area so not many.

No issues with either of mine, what are you using for the upstream connection?

Welcome to the forum. Have you tried, or have the ability to, use ethernet for the initial configuration by chance? If it were me, I would factory reset the device and start over.

1 Like

My upstream connection is xfinity with a pfSense router and Ubiquiti APs. I really don’t understand what that has to do with the LAN side latency though. I setup another branded router in the same spot with the same LAN side wifi SSID and channel and it works fine. As I said in previous posts, I have factory reset the router and upgraded it to latest firmware but the same problem persists. I did not try ethernet but I fail to see how that will help regardless of the outcome. The 5GHz radio works fine so it is likely ethernet may work as well. Problem is, I have no use for the ethernet connection so it doesn’t matter to me if it works properly or not. Also, there is literally zero configuration here, I factory reset and connect to the default 2.4GHz wifi with the default password and get the default IP address provided from the default DHCP range. At this point, pinging the LAN side, I get this horrible latency. How can I start over? This is a factory reset device with no changes whatsoever.