[GL-MT3000] Routing with Multi-WAN

I'm currently using my Beryl AX to connect to a Guest WiFI for internet access, and then my WAN port to a rack of systems on a few isolated networks. I want to be able to access both connections simultaneously.

Is this even possible, being that Multi-WAN modes are either "Failover" or "Load Balanced"?

If it is possible, are static route(s) the way to go or some other method?

Any opinions or suggestions would be greatly appreciated. Thanks in advance!

Pls explain in details what you want to do.

Load balance will use both connections. Data will be distributed to either connection but not what you can control.

May I know do you want to connect and access both connections (WAN and Repeater Wi-Fi) at same time?

I think you were supposed to config the routing table of the Beryl AX, go to LuCI page, find the Static Routes, based on your network topology, set the static route (your special access is the rack of the system, means that interface is WAN), another data such as normal access will via the repeater Wi-Fi (no required to configure).

StaticRoutes

Yes, sorry... I want to connect to both interfaces at the same time. Internet via the Guest WiFI and a specific set of networks (say 10.192.0.0/16) on the WAN port.

I figured I would need to use static routes, and I've tried configuring them. However I'm getting confused by two things (perhaps more).

First - which Multi-WAN configuration do I want to use? I'm assuming Load Balance?

Second - If I need to configure a static route for the 10.192.0.0 network, which interface would I bind it to exactly?

Thanks for your help!

  1. Failover and Balance both ok, it could not affect the step 2, just depends on your scenario.

  2. I think would like to know the gateway IP of the 10.192.0.0/16, so that can be added the configuration (if say the gateway is 10.192.0.254/16:

1 Like

Can you pls try @Bruce 's suggestions?
I think that is the correct answer.

I think I got this working? :grin: Still need to do some further testing, but things are looking promising!

I had to enable the static route, as you mentioned (thank you for that!).

But, I also had to turn off Enable Interface Status Tracking, otherwise it was only letting me use one interface to egress at a time. Once I did that, boom!

1 Like