GL-MT3000 with SSD in Rep Mode. Can't connect to 5Ghz on reboot

I have a GL-MT3000 (fw 4.4.6) that works fine in repeater mode. I can attach a SSD for a samba share while connected to the 5GHz and everything is works as it should.

If I power cycle the router with the SSD I suddenly can’t connect to the 5GHz network. If I remove the SSD I still can’t connect until the next power cycle. 2.5 GHz connection works fine no matter what.

I can connect on 5GHz If I take it out of repeater mode (with SSD) but I loose the connection once I reconnect it to my home network (on 5GHz as well btw).

I was under the impression that usb3 interference is in the 2.5GHz range. But I doubt it’s a radio interference issue anyway since the problem remains until I reboot.

Only errors in the system logs that I can’t account for are:
-EDCCAInit() [everything is set to 0]
-sta_send_auth_req: AUTH - Send AUTH request seq#1
-UpdateBeaconHandler : wdev(1) bss not ready (state:2, caller:ap_link_down+0x84/0x130 [mt_wifi]!!
-UpdateBeaconHandler : wdev(3) bss not ready (state:2, caller:ap_link_down+0x84/0x130 [mt_wifi]!!
-WpaEAPOLREtryAction() 7675: 4Way-MSG1 timeout with
-ExtEventBeaconLostHandler() AP Beacon OFF!!!

Hey :wave:

I remember about some issues with WPA3 - are you using WPA3?
If this is the case, try to lower the security to WPA2 only and try it again.

Nope, just a WPA2-PSK on all three (home, 5 and 2.5) networks.

Can you log in into luci when this issue happens and make a screenshot of the wireless settings?

Come to think of it, it could also be a power supply problem. Maybe the USB3.0 disk needs too much power, which causes the wifi module to fail or shut down.

It will be interesting to see if you can restart the Wifi module via Luci - because the fact that everything works again after a restart indicates that some important processes or devices are no longer active.

I don’t know what’s up with those reported signal and noise levels. Max transmit power is currently 17dBm but the router is only about six feet way.

If it were a power issue perhaps it’s something to do with the boot sequence? (I don’t loose 5GHz if I plug it in after boot.) Peek draw on that SSD when I plug it into my desktop with a usb meter looks like 35mA. Is there a way to delay the USB power up on luci?

EDIT: Chromebook reports signal as strong

Hm, I hoped that the screenshot will make it less difficult to point the problem.
Unfortunately, I don’t know any more steps to troubleshoot.

@bring.fringe18 Maybe you know how to troubleshoot this by using some magical SSH commands?

OP seems to be stating this issue doesn’t occur w/ the 2.4GHz & the SSD connected, only w/ 5 GHz but it really does read that the SSD is throwing some EMI.


Wrap a couple of sheets of aluminium/tin foil around the SSD & its cable… but beforehand do a site survey:

Can you get into LuCI & disable the mount point? I’d like to know what happens when you’re on the 5 GHz, Repeating, initially without the SSD mounted… then what happens when you manually mount the SSD.

Having Wifi Analyzer running while doing all that should be a considerable help. You can filter results to just your specific network (in this case).

You’re going to need to SSH into your Beryl AX. See:

The SSD might be a red herring… :man_facepalming:

With the SSD disconnected (and mount point disabled fwiw) I can no longer connect to the 5 GHz network if the router is in repeater mode to my unifi ap.

I can connect just fine if the repeater is using my phones hotspot.

Progress, I guess. It previously worked with my unifi ap. The only change was installing some usb tools and mucking about with the fstab so the drive would have the same mount point every time.

WiFiAnalyzer didn’t show any appreciable change in the network environment when I repeat the unifi ap vs not.

Hummm… see the full HOW-TO I posted ITT. I’d make a backup of all conf, including a list of all opkg you since installed, then reset to stock.

Nuke it. You can always pick out whatever pieces you need to restore fr the backup tarball.

Reset and reconfigured and had the same problem.
Reset and did nothing but set the timezone, repeater network settings and wifi settings and had the same problems.
I’m going to try an older firmware to see if there’s something not getting cleared out.

Turns out it was RF related but not from the SSD.

In desperation, I decided to do my fourth (fifth? sixth?) configuration in my shed, where my home wifi isn’t quite so well built out. No problems.

My guess is that a nightly optimization of my network between when I first set up the travel router and first had problems was the culprit.

1 Like