GL-MT3000 won't connect to synology with OPENVPN

I've connected my GL-MT3000 to my Openvpn account which is on my synology 423+. However, when I have the VPN switched on, it cannot access the synology DMS. I can access synology DMS through openvpn client on my computer while on the internet through my GL-MT3000 (VPN switched off) however. I have opened the port on my GL-MT3000 that is open on my home router and on my synology.

Any ideas why this won't work?

Hi :wave:t2:

please share a network diagram (see How to get support quickly ) and the log files.

I should note, I tried tethering with my phone and everything worked as it should. I also tried it at home on my home network using ethernet and it worked without a problem. So it just seems to be the wifi repeater that is having issues.

You can't VPN into a network the Wi-Fi repeater is connected to.

Try by using your phone as a Wi-Fi access point and connect the repeater to it.

The network I'm connected to with the repeater is not the same network my VPN hosted on my synology is connected to. They are on separate networks.

So the networks are not connected to each other except via the Internet?
That's important.

Correct, the network I'm attempting to access using my VPN (Openvpn client) is over 500 miles from where I am currently. When I use tethering with my phone, with the VPN on, I can access my Synology NAS. When I use a repeater with the VPN on, my Synology refuses the connection, but if I use my desktop VPN client application while connected to the internet via a repeater, it works and I can connect to the NAS. Only when I'm connected to the network in repeater mode with the VPN client turned on the router does it refuse to connect with my NAS.