GL-MT300A does not detect Netgear Aircard AC770S (AT&T Unite)

I bought the GL-MT300A-EXT and want to use it tethered to my AT&T Unite (AC770S) hotspot. When I go to the 3G Settings it shows “connect your modem” I can’t get it to detect the hotspot. All I could find in documentation is to use the advanced interface, but not where to go to enable it. What do you need from me to help me resolve this issue?. Is there a tutorial or starter guide that covers USB connection to a hotspot?

OK I found a tutorial here: I’m stuck in step 3 where it says to select dev/ttyUSB0 or USB1 or USB2. I don’t have any USB devices showing so I assume that my problem is USB device detection. I found this thread where DC-Unlocker had a similar problem detecting the modem. The modem has a feature where on first connect to a Windows or Mac computer it loads a virtual CDROM with the drivers on it. I thought that might be fooling openWrt so found a way to turn it off. Sadly it didn’t help. Other openWrt tutorials show a lot of command line stuff. Not ready to try that yet.

So my question is, do you need a log file to determine the problem? If so where do I go to get it?

TIA - Paul

Hi @ptiemann,

Could you please have a look at this openWRT article, which describes USB support in openWRT and check you have all necessary packages?

As far as I have played with USB modems (not with openWRT, though), I had to upload modem’s drivers (just a bin file) in order to get it recognized and operational.


Hope this helps.


Regards. :slight_smile:


I think it is because Sierra driver is not installed.

Can you pls go to “App” page from the UI. After the page loaded the software report and search “Sierra”? You will find Sierra driver please install them. Then reboot the device and try again.

Well, I’m a lot closer. I upgraded to the newest firmware and the modem is recognized. Alzhao, it seems all the right drivers are already loaded. I can’t access the internet though. I think I found an article that said I needed to enable ndis mode but it didn’t say how. It just mentioned terminal or putty and issuing at command, but not what they were. Any help greatly appreciated.

UPDATE: I found the article, it was linked from the OpenWRT documentation that age_killer mentioned. I haven’t found documentation yet on at commands for the modem.

can you ssh to the router? Then you will be able to issue some AT command.

Now sure what age_killer is.

Yes, I can SSH to the modem but I don’t know what at commands to issue. Age_killer is the other person who responded to my first post.

Hi @ptiemann,

I found following documentation from Netgear : AT commands, How to issue AT commands, AC770s user guide.

Hope these might put some light as to how you can change settings via SSH, also here is another OpenWRT forum thread that seems applicable to your issues.

Good luck! :slight_smile:


@ ptiemann


Hi there.

I saw this thread when searching for a similar solution to what you have posted on top. In my case an AR300M tethered to a Netgear 781s (Unite pro).

I have both the 770s and 781s installed on two different vehicles. They are both very good as modems ( i get 30-40ish mbps when tethered) as they really get good signal from cell towers and maintain it even when inside a moving vehicle but terrible as hotspots even when stationary. As I just installed a mobile plex server on one vehicle and successfully stream media between devices. But when doing failure resting of the set up I found out that now my main choke point is the mobile hotspot (770s/781s) as they also acts as routers between devices albeit in limited capacity, hence the need for the AR400M.

Do you have any update on your case? Got it working?

As I still don’t have my AR300m (on it’s way) so I won’t be able to add anything on this thread yet. So far by googling I have not found somebody successfully tethering it with either the Ac770s or the 781s. Otherwise, I might just buy one of those Ar300M supported sticks.


UPDATE: Decided to just buy the usb modem Huawei e397u-53 unlocked. Found a a great deal over at at ebay. That way I avoid messing around with drivers and other stuff. Will just transfer the freed hostpot (Netgear 781s) to a third vehicle or something. Thanks anyway.


I haven’t got it working tethered via USB but I do have it working in repeater mode. Frustrating as it connects and shows as connected in the UI. When it connects it I see no errors, however, no traffic works from a connected client. I think I’m just missing something small but haven’t found a working recipe either.

Are you using an external antenna on 770S or 781S?



No external antennas on both as I try to minimize wires and saw in a couple of postings that the external antenna connectors are fidgety. What i did is just put them inside these sun visors (not the exact one but similar)
Worked great with easy reach for turning on and off.

Got my AR300M 2 days after my initial post. Was able to set it up easy with my mobile OMV Plex server. Performance was great (just had a 2 hour road trip with the kids in tow): 7 devices simultaneously connected to the AR300M with 3 of them as tablets streaming media. Kids had a great time both ways. The unlocked Huawei e397u-53 (Cricket) I posted above matched well with the AR300M. Even it was advertised as T mobile specific it also worked great with an AT&T sim. The fastest internet speed using an AT&T sim was 10 mbps (download). Slower than the 781s but for my purpose it was perfect as I was able to bring into local all the media that I want to bring via the OMV plex.

The great thing with the AR300M is it migrates automatically from one internet connection to another (WISP to USB modem) when the vehicle goes out of ranged of my home wifi unlike before I had to go through the OMV plex server which I was running headless.

@Sakuji, I am happy to see that the device work for you and the multiple WAN just works as expected.


Commending you for the great support you and your company has been providing. I’ve seen good feedback in different forums about your products and the support you provide. Keep it up.

I actually just did some failure testing on your AR300M. So far has been performing great. Very stable with low power consumption.

Because of this I’ve been thinking of buying another one of your routers (or two) to act as hyperlocal (and very low power) hardware-based vpn clients to a couple of servers I have here at home as i’m having hard time maintaining vlans on certain subnets with sensitive info in them.

Again, keep it up.

Hoping to get this resolved. I really need to get the GL-MT300A to work over USB with the AT&T Unite 770S.

To summarize:

  • After upgrading to the latest firmware the GL-MT300A does recognize the hotspot and I don't have any errors shown. It just seems that DNS doesn't work. I can't get any web pages to work from a connected client.
  • It does work if I connect using repeater mode but I would expect that a USB connection would be faster, as repeater mode halve's my WiFi throughput.
  • I've tried everything I can think of to get this to work. Repeater mode works fine, a direct connection with USB connects and shows an IP address but won't resolve web requests.
I really want this to work because, for some reason, I can't get half my devices to connect over WiFi to the hotspot, however as mentioned above, the GL-MT300A connects with no problem as a repeater.


@ ptiemann

Just saw your post. Lemmi try and help you out coz this dedicated hotspots are particularly tough and reliable. It would be a shame if we won’t be able to use them with the ar300m as you described. Aside from that, i also cannot find anything on the Internet for somebody having a success doing this. So you might be the first.

Thing is I don’t have my Unite 770S (currently lent out to my brother’s son who went to a two week camp). So just the 781s.

Can you describe here what you did when you directly connected the hotspot via usb to the ar300m. Coz i tried doing that with my 781s but when I checked the “Internet Settings > New Connection > Tethering” it won’t recognize the 781s. All firmwares updated and tethering mode activated on the hotspot. I even checked things via luci for anything to no avail. So I decided to check with you first before I do anything through ssh and break something.


Anyhow, my 770s will be arriving in a few days and will try it there too. Coz based on your description I think it might just work since the 770s has been recognized and gave out an IP. Since both of these are full routers, perhaps there was a conflict with their dhcp. My thinking is to deactivate one of the dhcp and just set it into passthrough/unmanaged. I just can’t do it yet with the 781s since it won’t even get recognized by the ar300m.


Keep me posted.


I ran through these steps again this weekend to make sure.

  1. Reset to factory settings by holding the reset button for 10 seconds
  2. Logged in set password
  3. Attached the 770S via USB
  4. Restarted the router via the restart button in the gui
  5. Selected Add Connection
  6. Selected 3G/4G
  7. Selected: US, AT&T
  8. Selected the modem (I don't have that path at the moment. I thought I saved screenshots but didn't.)
  9. It shows connected and gives me an ipaddress. At this point, everything looks good but when I try to connect to a page I get a DNS error.
  10. If I connect as a repeater it works fine.I'll have to go through this again and get screenshots.

So it’s been a year since I first posted this and I still don’t have it working. I am trying to use the USB connection of my Netgear Aircard 770S hotspot (aka MiFi) to get to the internet from my GL-MT300A. The router detects the 770S as both a 3G/4G modem and tethered device but reguardless of which option I use when I try to access the internet from any client via Ethernet on the LAN port or via wifi not addresses will resolve. I can make this work if I set it up as a WISP repeater but I know that is slowing down the wifi connection.

Does it show ttyUSB and wwan0?

If yes then it should be qmi mode not tethering.

Can you try agin like this step:

  1. Reset the firmware and clean everything
  2. Unplug it he power
  3. Power on and Set up as QMI mode

Pls also post screenshots that will help

If not work maybe need to try ROOter firmware.