GL-MT300A factory reset doesn’t work

hey there community,

recently purchased, one GL-MT300A and one GL-AR300M they’re seeming preety easy to use. No issues with AR300M, factory reset works and everything is up to date and working. Although with MT300A, after last firmware update it stopped working and reset button doesn’t work no matter how many seconds you hold. There is only one green light when you plug in and when you try to reset nothing seems to be happening. Wifis don’t recognize the router on multiple computers. Something went wrong and i’m very sorry about this. I guess it’s broken inside somehow.


any help appreciated,

best regards all.

I don’t know what is happening but seems it does not boot. If it doesn’t boot, you cannot reset it.

Please try flash the firmware using uboot

Hey again, i have to bump this since i tried recommended solution but it looks like working but doesn’t. All goes according to the video but still no routers no pc or phones are recognizing the MT300A. I have no use at all. I all wanted was to use it as repeater but i feel like kinda helpless olease tell me what to do ?



as I don’t have a clear solution I suggest you to return the MT300A router.