GL-MT300A - No Wifi signal anymore


I set up my brand new GL-MT300A at home, I bought a case for it, and I went on a trip. Having arrived at a hotel put a LAN cable into the GL-MT300A LAN port and connected the USB for power.

No Wifi signal is visible to any of my devices, the green lights are on, but no Wifi.

Any suggestions for troubleshooting?



Did you use it as WISP Repeater at home? If yes see this: Overview - GL.iNet Docs

Yes, I did leave it in WISP mode. Hitting the reset button made Wifi visible again. Maybe this problem could be avoided on the software side?

Thank you very much for the helpful suggestion.


we are solving this problem now. We used shell script to disable sta if not able to connect, but the efficiency is low.

We are now writing software directly communicate with ubus, netifd and wpa_supplicant to solve this problem.

My GL-MT300A seems to be in the same state.

From reading above, it appears factory reset is the only solution? How long do you hold the reset button down for?

If you have an Ethernet cable and a PC you should be able to connect to the devices LAN port and manually reset the wireless config.

The easiest thing is to go to Advanced Config at the top right and log into Luci. Goto Networking => Wireless and select the STAtion (Client) and “Remove”, then OK. Wireless should restart and you can then connect to the new STAtion, probably with out rebooting. Use the GLi GUI to connect to the new STAtion. Its much easier to use than Luci for this.

You may be able to just go to the GLi GUI and scan for a new STAtion, but I am not sure.

If you have customized your settings (IP, AP credentials, etc) you may want to make a backup of the settings and keep this on a USB drive. You can then reset the device and restore the settings. You probably want to leave the wireless STAtion unconfigured. If you installed packages, these will need to be reinstalled or some functions will not work.

To answer the question, Factory reset is more than 5 seconds

Thanks – I hadn’t thought of connecting to it using an Ethernet cable. Got it working again using that method.

I love it when a plan comes together!

Please try firmware v2.21, which solves repeater connection issue.

On a WISP connection: when I switch (while on a wifi connection, not LAN) from one wifi access point to another, it works, but when I switch back, it doesn’t, see image attached.

I can switch back to the original wifi access point only when I am connected through LAN.

I would like to switch back and forth while on wifi.

Could this be implemented?

Thank you,


I think this is a bug. It should work.

Can you use the repeater manager directly? You can choose which ssid to connect in the “saved ssids” page.

@ Russel Coight,

I get those same types of errors when I use WISP. Sometimes it works, some times it doesn’t. I often have to do a full factory reset if I want to connect to another access point.

Not sure what you mean by that. Could not find any saved ssids page.

Anyway, I was able to switch back and forth between different wifi networks remotely, so without a lan cable, with Firmware version 2.25 installed.