GL-MT300A openvpn soft, auth-failure received


#1

When I build up an openvpn connection with certificate verification this works without problems. If I use account verification, I get the message soft, auth-failure received, process exiting.

What could this be?


#2

Wrong password or username.


#3

No, checked several times. And username password are good. Because it works from my laptop with the openvpn client with the same username and password.


#4

Would it caused by your username or password have special characters?


#5

Not really. Are just a few numbers and letters.


#6

This is usually (95%) caused by wrong username and password. You can verify this on a pc to see if the username/password works.

I did have one case that this problem is caused by another reason. But I cannot recall the reason.


#7

If they’re establishing an OpenVPN connection on startup - might be the entropy pool blocking things… on AR300M, this can be up to 90 seconds before the pool is full enough…

On the MT-300A, might be similar.

There’s some time of day sensitivity as well…


#8

I contacted PIA a while back they suggested adding

pull-filter ignore “auth-token”

to the ovpn file. This solved it for me.


#9

@sfx2000
No, the connection is not made ad startup. So that can’t be the problem

@alzhao
As you have can read previously, I can connect with the same username and password when I use the openvpn client on a windows computer.


#10

@nopro404
Thanks, but unfortunately with this option I still have the same error message


#11

If you are cutting and pasting the user/pass, then you are probably grabbing an extra space at the end or start.
Enter the details manually.


#12

Are you using the 2.7+ firmware before 3.x? There is a bug in startvpn script.


#13

Where can I see that? because mine indicates: Current Version 2.264. And that it is up to date


#14

You need to manually install v3 from here:
http://download.gl-inet.com/firmware/mt300a/testing/


#15

After updating to version 3, and back to the original openvpn config file. (pull-filter ignore "auth-token" removed) And now I have a connection :slight_smile:

Only get no data through it. But that will be a route problem, I think…