GL-MT300A overwritten mtd2 & mtd7


#1

During some experiment with openWRT I overwritten factory and art partition now I want to try your new firmware and the log is full of:

Sun Dec 30 18:01:35 2018 user.info : 272: gl-sdk>> Read factory info failed.
Sun Dec 30 18:01:35 2018 user.info : 272: gl-sdk>> Read factory info failed.
Sun Dec 30 18:01:36 2018 user.info : Read factory info failed.
Sun Dec 30 18:01:36 2018 user.info : Read factory info failed.
Sun Dec 30 18:01:36 2018 user.warn : [ 247] gl-health>> Check factory info failed!
Sun Dec 30 18:01:37 2018 user.info : 272: gl-sdk>> Read factory info failed.
Sun Dec 30 18:01:37 2018 user.info : 272: gl-sdk>> Read factory info failed.
Sun Dec 30 18:01:37 2018 kern.warn kernel: [ 119.290819] ieee80211 phy0: rt2800_config_txpower_rt6352: Warning - ignoring EEPROM HT40 power delta: -2
Sun Dec 30 18:01:38 2018 user.warn : [ 247] gl-health>> Check factory info failed!
Sun Dec 30 18:01:38 2018 user.info : Read factory info failed.
Sun Dec 30 18:01:38 2018 user.info : Read factory info failed.

With old firmware 2.xxx the gl interface load no problem but ddns give some http://�����.gl-inet.com/ weird output
The new interface (FW 3.0) load after a lot of time and ddns is not usable anymore
Please help me

Best regards


#2

You erased the factory data. Seems you also erased the radio data, which will cause the wifi doesn’t work.

Please send private email to support@gl-inet.com, with your router bottom sticker. If the info can be found back then you can write them back. I am not sure for MT300A the data is stored in factory.


#3

I sent the email. By the way what kind of operation is done with factory partition and art partition?

I have an ar150 too and I didn’t see factory partition


#4

It is art mtd, storing the radio calibration data and MAC address etc.


#5

Thz what about factory partition?


#6

My mistake.

Art partition is for Atheros.

In MTK it is factory partition.


#7

I sent a new e-mail with correct data


#8

I bricked my router MT-300A overwriting factory partition with art partition of my AR150 in an attempt to fix the problem (I was thinking that only MAC S/N were in factory partition)

Please help me now it keep reboot I can still access uBoot @alzhao


#9

No you cannot do that.

Seems I sent you the config.bin, so still need to send other data right?


#10

Yes I need all the factory partition, please


#11

sorry I forget if I solved your issue via email. The radio data is lost and we have to copy from another router. We don’t have radio data back up of MT300A.


#12

So I just have to throw it away?


#13

If you have access to u-Boot, you may be able to restore all the partitions by copying from another MT300A of the same HW version…

Can’t remember at the moment where the MAC addresses are stored (factory I think on the mediatek devices), so you’ll end up with a clone, but if one knows the offset, one can hex edit the file and change those octets back to the original…

That’s all contigent upon uBoot not being borked of course, and one having the appriorate USB-UART cable and appropriate skillset to get into the deeper gubbins…

These things are almost impossible to totally brick unless uBoot is messed up, and even then…


#14

So no one has GL-MT300A???


#15

Do you still need the data of an MT300A?


#16

Yes please I need it


#17

Any news? I hope to receive files


#18

Sorry, do not enter the forum since I asked, mtd7 I think it’s the partition you need?


#19

Here it isart-mtd7-backup.zip (212 Bytes)


#21

And mtd2 factory partition
factory-mtd2-backup.zip (507 Bytes)