GL-MT300A Trunk build available

I have built a Trunk image.

You must login via SSH and set password via “passwd”.

preinstalled mc, nano, samba, LUCI, usb and sd card support. Automounts usb and mc to /media/usb and /media/sd

Reset button toggles wifi, or (long push) reboots device (look at /etc/rc.button/reset). Program the switch at /etc/rc.button files BTN_O and BTN_1.


I cannot upload do to filesize limit. Please change to 10mb, Alfie, so that we can share builds.

@brother, please contact me @

I’d be more than happy to host a download mirror for builds.

okay, thank you, Justin. You are free to download it here:

If you want to host it on your own site, feel free, filefactory is kind of miserable.



Sure thing. Here is a permanent link to the file:


Also - Thanks for making this. I got it running on my MT300A, seems to be working good so far. Only thing is, I had to install luci from the command line, is it not pre-installed?

Thank you again for making this image. Very helpful.

I tried it. Maybe it is a good idea. But impossible install many packages:
<div class=“cbi-value”>

Installing openvpn-openssl (2.3.10-1) to root...

<pre class=“error”>Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for openvpn-openssl:
  • kernel (= 4.4.7-1-e52d172a70159a6f481440d646522d71) *
  • opkg_install_cmd: Cannot install package openvpn-openssl.


Did you first run??

opkg update

Trunk builds keep the package lists in RAM, as far as I know: you have to update after every reboot. I had no problem installing openvpn-openssl.

Maybe you would also be happier with:


opkg install luci-app-openvpn

Yes, of course, opkg update - first, and second:

root@GL-MT300A:~# opkg install openvpn-openssl
Installing openvpn-openssl (2.3.10-1) to root…
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for openvpn-openssl:
  •  kernel (= 4.4.7-1-e52d172a70159a6f481440d646522d71) *
  • opkg_install_cmd: Cannot install package openvpn-openssl.


root@GL-MT300A:~# opkg install luci-app-openvpn
Package luci-app-openvpn (git-16.108.33174-51a7f96-1) installed in root is up to date.

But OpenVPN with this package, luci-app-openvpn, without openvpn-openssl (or openvpn-polarssl) - don’t working.

I am not sure you are running this build. I am not having these problems.

I can confirm these issues as well - I get the error about satisfy_dependencies_for - I have run opkg update as well.

I do wish I could be of more assistance, but my skills are not the best when it comes to OpenWRT trunk images.

@mvn2000 @Justin, I didn’t try. But this seems a common problem of OpenWrt trunk. Trunk is upgrading daily. The repo is built from time to time. Once new repo is built, your firmware will not be able to install kernel modules again. So, you need to download the most recent firmware again (from OpenWrt official built) and then you will be able to install.

I already downloaded and installed official build from OpenWrt site. Yes, it working, But this official build is completely empty, no mc, nano, samba, LUCI, usb and sd card support… I installed LUCI, OpenVPN and all other things and decided to test button. Pressed it long, and… my router empty again! :slight_smile:

Official Trunk builds from OpenWrt contain none of the packages noted by default. If you install them and press reset they go away. The router is reset to the factory default contents. If you build your own, when you reset the device it will revert to the built image contents.

If you download trunk, you should also download all the packages as of that point in time (300mb or so if I recall) and save locally. If you read the wiki, you can find the details on how to install local packages.[]=local&amp;s[]=package[]=local&amp;s[]=package

I copy packages to the tmp folder (via SCP) and install from there. Tedious, but not difficult. You also need the dependencies, which may be more of an issue to identify.

TIP: keep a text file of all the packages and the dependencies you install. format this into an opkg statement and save it along with a config backup. It significantly speeds up a rebuild.

Did you reset to factory defaults when you flashed?


Can you post this output: cat /etc/opkg.conf

@alzhao Thanks for the information about OpenWRT Trunk.

Also, has anyone attempted to build a trunk image for the MT300Ns as well by chance? I may attempt to build an image if there are none out there at the moment.

Seems I need to prepare our own imagebuilder so that you can have your own firmware in 30 minutes.

It takes me 3 months to make the firmware working correct on my router.

@brother, @alzhao I have used this image for my new mt300a. It works great!

But there are a slew of packages that I would not need (zc, even apache etc). When I tried to remove through opkg remove ‘pkgname’ none of the packages get removed. I am really short on space, and got to get rid of few large packages.

Any idea on how to remove some packages…? Much appreciate

Packages that are built into the image can not be removed. Only packages added to the device after flashing can be removed.

Like Ranger said, the partition you are modifying is only the overlay, when you use opkg. In fact, deleting things can take up more space on the overlay and will not give you more space.

IF you have special needs, just build your own with the image generator: Image Generator (Image Builder) - EN [Old OpenWrt Wiki] --It is really not that hard and is a good opportunity to work with virtual machines, linux cli, etc. I suggest virtual box and ubuntu server.

Otherwise, continue to pester @alzhao about a clean build, which I thought he was going to make, as he has already done for the AR150: GL.iNet download center