GL-MT300N - owner

I have GL-MT300N and I would like to use in public place like hotel or so. Can someone please point to steps needed.

where I would like to connect to WAN using wifi and also connect my devices to GL-MT300N via wifi using routing and DHCP of

GL-MT300N. - once this is done then may be VPN.

does GL-MT300N has one Radio (wifi) or two ? (thinking need separate wifi as wan and Lan wifi)

Thank you




GL-MT300N has only one radio, it can act as repeater, which means you can connect it to wifi and then connect your devices to its own wifi. It has the problem of “one radio” repeater. You can check this to see how to solve it: Overview - GL.iNet Docs

thanks , I am able to work in repeater mode, but can you also point me to the documentation or some recommendation on which usb wifi dongle works with MT300N.

I do have EDIMAX EW-7811un which is USB wifi dongle based on RTL8188CUS very common, but I am not able install the drivers fully so it does not work. Can you please point me to any documentation on how to add second USB wifi dongle to MT300N.

Thanks in advance



I never got my question answered for second wifi - so I kept looking for solutions.

built in wifi is using Chipset: Atheros so I ordered usb dongle wifi based on Chipset: Atheros AR9271 paid around $9.00 but cheaper can be found.

after plug in Gl UI did not find it nor Luci - putty to Gl-Mt300N typed wifi detect it found the radio1 and then I cut and paste into wireless file in /etc/config . reboot the GL-MT300N and now Luci shows both the radio and now you can configure now built in one as lan / AP and other one as client/wwan for Wifi of public place .

you should have similar output of wifi detect

config wifi-device ‘radio1’

option type ‘mac80211’

option hwmode ‘11g’

option path ‘101c0000.ehci/usb1/1-1/1-1:1.0’

option htmode ‘HT20’

option txpower ‘20’

option country ‘CN’

option disabled ‘0’

option channel ‘1’


config wifi-iface

options for radio1 …

I know all of above can be done with one radio and use run button script to recover from lock up.

actually RTL8188CUS should also works. Maybe you need to install a kernel driver.

I had the EDIMAX running on a different device. This post details the config.

It seemed to work at first, but later I had some speed issues. Some have reported that using a USB cable to put distance between the devices helped. I just went to a Buffalo device, which performed better, but still not as fast as the single radio correctly configured. Definitely easier to manage things with 2 radios.

I had downloaded the package and tried to installed but was getting error at installation , I was not sure if I was doing something wrong . I will try again and post error later this week.

To make it easy for others can you please post the specific device info (make\model) and packages you installed to get this operating?

I had found and looked into your openwrt post and was not able to install or detect. I will try again on weekend.

wifi dongle I am using is AR9271 bought from Amazon

It is very generic part # printed on is PW-DN4210D , did not even come with any documentation not a single page but windows will find it and works.

ebay has same chipset for cheaper they should also work.


@nick7920, for AR9271, you need to install kmod-ath9k-htc, which is the usb driver for AR9271

@alzhao - you are right when I was trying to make mine EDIMAX dongle work I had applied the rtl-sdr_2013-06-12_ar71xx.ipk and librtlsdr_2013-06-12_ar71xx.ipk may be that made my AR9271 work - but after your email I reset the router and I had to apply kmod-ath9k-htc and reboot before AR9271 would work again.

When I applied the kmod-ath9k-htc package I did get errors

on every single script of sub packages I get similar error

Collected errors: * pkg_run_script: package “ath9k-htc-firmware” postinst script returned status 255. * opkg_configure: ath9k-htc-firmware.postinst returned 255. *

but after reboot AR9271 is working .



255 errors are caused by unknown reasons. Generally it doesn’t matter.