Gl-mt300n-v2 2.7 firmware for downgrade

Hello,

I am searching for a pre 3.00 version of Gl-mt300n-v2 firmware (maybe 2.7x). Would someone be able to provide me with a valid link please?

Why, will you ask? Well, this is why :

I updated my Gl-mt300n-v2 to version 3.012.
I use purevpn, and since the update, I cannot connect to their service with openvpn anymore.
I tried 3.022 testing version, and I have the same problem.

furthermore, the pptp menu has been removed from this update, but I absolutely need it sometime.

Therefore my initial question :slight_smile:

Thanks a lot

https://dl.gl-inet.com/firmware/mt300n-v2/v1/

at 3.x version, please try wireguard

I use purevpn on a number of devices using 3.x without issues. When I get a chance I’ll post my configuration so that you can compare.

@Leo purevpn doesn’t support wireguard.

Edit:
Here is my OVPN file to connect to the sydney server using UDP.

client
dev tun
proto udp
remote vlap-ukle1-ovpn-udp.pointtoserver.com 53
persist-key
persist-tun
ca “/etc/openvpn/ovpn0/cert/201810201331-ca.crt”
tls-auth “/etc/openvpn/ovpn0/cert/201810201331-Wdc.key” 1
cipher AES-256-CBC
comp-lzo
verb 1
mute 20
route-method exe
route-delay 2
route 0.0.0.0 0.0.0.0
auth-user-pass /etc/openvpn/ovpn0/auth/usrpwd.txt
auth-retry interact
ifconfig-nowarn
auth-nocache
daemon

up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf
script-security 2

I had to package up the crt file as well into a zip file

Thank you both for your time.
@Leo, I can’t use wireguard with purevpn, and I still need to get pptp working.
@heytrey, thanks, the crt must be the reason it doesn’t work in openvpn.

Nevertheless, I still need pptp (@heytrey, purevpn don’t propose their “Netflix” VPN in openvpn), so I still need to downgrade.

Does somebody have a link to a V2xx firmware?

Hey guys,

The new router package from purevpn includes the crt file, openvpn is therefore working. Thanks @heytrey for your insight.
Nevertheless, I still need to be able to use PPTP, and therefore still need the old 2xxx firmware.
thanks again.

2.x firmware has serious security bug so pls do not use.

Thanks for your answer @alzhao, but to be honest I don’t care much about security on this device because it is restricted to my “streaming devices” and has no access whatsoever to the rest of my network.

My problem, however, is that I chose this device because it had openvpn and pptp clients embedded, and now I’m stuck with wireguard (which is nice but of no use to me) and no more pptp, which is a serious drawback in usability for me…
that’s why I’m still trying to get the old firmware in spite of its flaws.
thanks anyway :slight_smile:

for pptp, if you do not mind, you can create one in luci. Go to network->interfaces and create a new interface and choose pptp.

If this is a problem we can send you v2.27.

Thanks @alzhao, since I never used it, I didn’t though of Lucy.

I can try this option first. As long as I can activate pptp at will it should be OK.

I just updated to 3.026 in order to be up to date before messing with this.

I will try to understand, and let you know.

Hello,

I tried to look at this guide :

https://openwrt.org/docs/guide-user/services/vpn/pptp/client

But it will be way beyond my wife to switch from an openvpn VPN to a pptp one, so I didn’t follow it.

Therefore, @alzhao, if you could send me the 2.7 firmware for my Gl-mt300n-v2, it would be greatly appreciated :smile:

Thanks again for your help

@kyson-lok pls send v2.27 with security patches for MT300N-V2

@Merlin09 Please download the v2.x firmware of MT300N-V2 from https://dl.gl-inet.com/firmware/mt300n-v2/v1/, which has fixed the security vulnerability.

Hello,

Thanks for that. I downloaded the firmware, but before I update my unit, @kyson-lok or @alzhao, could you confirm that it’s the right one, since it says lede in the name and I thought it was a special version?

It is the correct one.