GL-MT300N-V2-2e8 phone hotspot

I just bought a GL-MT300N-V2-2e8 and I successfully connected to the USB port a Huawei E8372h-153 wingle (wifi-USB) that is recognized as Tethering and, when connected to a power adapter, as wireless repeater. I also checked a ZTE MF833U1 (USB Modem) recognized again as Tethering. I also have an old TP-Link MR3420 with ROOTER Firmware and both modems works perfectly connected to the USB. I can also connect the GL-MT300N-V2-2e8 to the TP-Link MR3420 as wireless repeater and it works fine.

What I cannot achieve is to use the hotspot from my phones (Huawei P30 pro and LG G7Thinq android 10), that works great when used with the PC, with the MT300N-V2. When I scan the wifi it finds the hotspot created and let me insert the pwd but it runs trying to connect for a while and then it says Time Expired. Is there any other parameter that I should check/modify maybe with luci?

If I check the phone hotspot connection with the PC I notice that the security type is WPA2-Personal and that cryptography type is AES. Is it that that might prevent the connection with the MT300N-V2?

As an additional test I tried to connect the Huawei P30 pro to the Wifi HotSpot Manager of the TP-Link MR3420 with ROOTER Firmware (similar firmware then GL.iNet and almost interchangeable) and it cannot connect. However if a use an old phone with android 5 it gets connected and the same positive results occurs with the MT300N-V2. I also checked that, when connected to the PC, the security type is WPA2-Personal and that cryptography type is AES the same of the P30pro. So that I might exclude a security mismatch. Now I think it might be something in the android version but who knows?

Third test: I used a Samsung S3-I9305 with LineageOS 16 (android 9) and it works both as tethering and as wireless repeater. I then retested the Huawei P30pro (android 10) and it works only when in USB tethering mode. The same occurs to LG G7Thinq android 10.

I don’t have a clue of what’s occurring, i.e. why the wifi repeater connection time out without connecting. I need it!

I have ever saw one samsung phone hotspot. In the phone it has a choice: “use 5G first” or something like that. It means that, the phone may output 5G signal or 2.4G signal. While the router can only see 2.4G.

So if you have that option, just check if you can output 2.4G hotspot only, not 5G.

I obvioulsly had the P30pro hotspot using the 2.4 Band otherwise is not even detected by the router.

I did several others analysis where I was finally able to connect to the LG G7 ThinQ with android 10 by first disabling the wireless security and it got connected and then, once reenabled the security, by changing the hostpost band from auto to 8 it got connected too. However the P30pro with Emui 10 does not have the possibility to either disable the security nor choosing the band so that it cannot connect. Whenever it does connect the wifi_join return=0 while if it cannot connect the wifi_join return=-5.

This is the system log with Luci

Tue Nov 24 12:01:23 2020 : [ 617] gl-sdk>> bIsSaved=0, ssid=HUAWEI P30 Pro, encryption=psk2, bssid=20:DA:22:C1:10:D4, wds=0, device=mt7628, identity=, channel=1
Tue Nov 24 12:01:24 2020 : [ 1657] gl-wifi-core>> FirewallConfiged
Tue Nov 24 12:01:27 2020 : [ 2205] gl-wifi-core>> bIsStaEnabled=1
Tue Nov 24 12:01:52 2020 : [ 623] gl-sdk>> wifi_join return=-5, channel=1
Tue Nov 24 12:01:52 2020 : [ 1406] gl-wifi-core>> Restart wifi…

I finally found the culcript: it was the name I used to identify the phone hotspot. It seems that it was somehow not properly formatted. By first changing to Huawei only the name of the hotspot it was recognized. Using - or _ between the various part of the name continued to be acceptable. Then I started to insert spaces and it got connected all the times.

LESSON LEARNED: the router was not to blame!

1 Like