GL-MT300N-V2 adblock problems absolute nightmare

I’m using luci adblock on my Mango V2. When the lists are downloaded successfully, they are saved on usb because it is an absolute nightmare to try and update them. They always fail to resolve or fail to prepare with an RC-2 code. I have to restart the process 10-20 times. Is there a fix? EDIT: I put a 2 min delay on the start of adblock process to prevent overloading the CPU. Firmware is latest 3.215.

Please find below a log:


Ok. So after some tests, here is my partial solution. Adding a 2 minutes delay is mitigating the issue. Setting adblock as a background service is also helping. It does fail at “preparing” stevenblack list RC-2 half of the time, but it’s not failing everytime. Also, using usb blocklist backup ensure you’re never starting exposed provided you wait for the adblock process to start.


Final update. Setting the number of queue to just 1 solved everything. So:
2 min startup delay
Set as low priority service
Set queue number to 1
Save blocklists to USB

Problem solved.