GL-MT300N-v2 aka Mango first use not working via lan or wifi

I have bought GL-MT300N-v2 a while back never used it, just opened the box and as instructed it did not work. I hope this is a common issue where there’s solutions. I’m thinking tftp flash but what server ip should I use to do so?

Try to reset it. Press 10s the reset button until the led blinks rapidly (after 4s it will blink then after 10s it will blink faster).
Then connect to it using the GL wifi or LAN port on then update its firmware.

ah for some reason I did not think of this as a normal router having a reset button lol derp ty I’ll try that

Not working out. I’ll risk tftp later

If it’s been in the box for a while, firmware probably out of date.

You’d be best to uboot the latest firmware onto it. Bit easier than TFTP :slight_smile:

I’ve flashed it twice, still not working. Cleared cache, tried other browsers and pc’s it doesn’t work.

I feel I need to update the uboot image as well under
only problem is which image? I do not see mt-300n-v2 so has to be under something else right?

Nothing worked, I wish I tested when I recieved it now I feel I was duped.

I bought it from aliexpress too. Tried older versions etc. It seems to work flashing no problem but accessing the actual gateway seems impossible. I think I need to flash uboot as well, would anyone know the proper image\bin?

Are you trying a wired connection to the LAN port? Or a wireless connection?

Wired, I do not see any wireless ssids to even connect to. I really regret not trying it out for a replacement when I first bought this instead of waiting a year until I needed to use this

The mango starts up as Perhaps with a laptop you make a wired connection to the LAN port, and set the IP of the laptop to 192.168.8.x with .1 as the default gateway and see if you can browse to

First, you need to find out if the router really boot. How about the LEDs? Which is on after you power it up and wait 1 minutes?

Uboot does not work? In which step please?

First one, being the closest to the reset button. Is on when powered and stays that way.

@elorimer works if I set on another router, doesn’t on the mango. I think I need to update the uboot and not just the firmware. Where can I find the uboot image?

Although this guide is pretty simple Can't access web Admin Panel - GL.iNet Docs

You need to tell me which step you have problems. The pc cannot get IP? What about LED status?

Unable to access web ui via and unable to see wifi ssid or connect by manually adding. (Unable to access after unboxing first time use and after flashing firmware to multiple versions, old or new except for uboot flashing which isn’t the firmware itself)

Led status solid light (LED #1 = being closest to reset button)

Can you just talk to customer service to get an exchange? Do not toutch uboot itself.

Its been a year since I bought it or longer, I don’t think they’ll exchange it or that anyone will believe me after a year or so I tried to use it for the first time. I also unboxed 2x tplink ax10 routers from like 6 months ago, just found out they can’t be flashed to openwrt so that’s another problem I have. I’m someone who ends up buying a bunch of items from aliexpress or amazon on sale and use it when I need it. I will for sure test any tech when received in the future.

I’ll still contact them I guess, see if they have a fix at least.

for anyone experiencing this issue I will come back and post solutions otherwise I have found 0. So hope this thread is still alive for anyone to help out ty

No hurt to ask. I have notified customer service.

Thank you for helping out I’ll contact them now =)
I’ll post any solutions when I do, ty again

Edit: Contacted via the link below unless there’s another way since I was only able to send topic subject instead of the description. Thanks for the push to contact

Contact Us - GL.iNet