GL-MT300N-V2 Cable connection issue

Hello everyone. I have been using glinet router for a while satisfactorily but last night I suffered a short power outage. Ever since then, the cable connection completely does not work. Sometimes it does not even register a cable connected to the WAN port, but usually it will register the cable connection and ask me to choose to connect via DHCP, Static or PPPoE. Regardless of which option I pick, it does not work. I usually use DHCP and was using DHCP before it stopped working, but now every time I connect via DHCP it will start loading for a few seconds, say “Success!” and then the router will disconnect (even if I have connected the router to internet by tethering / wifi). When I reconnect it asks me to connect via DHCP again. The process repeats and it is slowly driving me crazy.

I have managed to connect via DHCP on one occasion, but when I did, the internet just did not work at all. There was no internet connection registered.

Things I have tried:
Reseting the router to factory settings - I tried this, no effects.
Using a different ethernet cable - tried this, no effects. I have a spare router and connected the ethernet to it, and it worked just fine, with internet working as well.
Upgrading firmware - I tried this, no effects.

Do you have any tips? I have this imgur link attached so you can see screenshots of the process with added captions for your help.

You could try changing the WAN port to “use as LAN” and connect your PC to confirm if the port is physically damaged.

I don’t have an ethernet port on my Mac sadly. Is there another way I can test if the port is physically damaged? I don’t think it is physically damaged, it has been working for a good few months, only issue came with the lost of power I believe. Also on rare occasions the ethernet has actually connected properly, but then the internet continues to not work. Thanks for your assistance in any case.

Update, I have tried something else. I have changed from DHCP to Static and initially it came with some success.

I was able to connect the cable which seems to show me that it is both not a cable issue or an issue with the port itself. However the internet continues to not work.

Chrome gives me a “DNS_PROBE_FINISHED_NO_INTERNET” error while saying No Internet.

Does anybody have any ideas on how to solve it? I feel the solution is very close.

Anyone have any ideas on how to solve this?

That IP ( does not seem to jive (technical term) with your default gateway and DNS.

It sounds like you don’t have another ethernet device (laptop, desktop, tv box, alternate router, etc) to test, but you can try another ethernet cable as well to see if that works. You may also have to power cycle your modem if you swap devices.

I’m not sure if you have Luci available, but you may also have the option of switching the WAN port with the LAN port if you want to confirm if it was damaged by a surge.

Possibly just getting the static IP information correct will get you online and allow you to progress your troubleshooting. If it is a 192.168.5.x scope (IP address provided by your modem), possibly try:

Subnet mask:
Default Gateway:

I’ll try your suggestions, thank you very much.

As for the static IP addresses, I honestly can say I just put them in at random based on the prompt. I usually used DHCP. I’m not a very techy person so I’m guessing this was not the correct thing to do.

Okay. Then you may want to post your modem model number because it can be a variety of IP addresses from DHCP (we can find the default IP).

If you do have another device with ethernet (that you can access from your phone or Mac), you can also plug it into your modem to confirm what IP addressing information DHCP provides. Be sure to unplug your modem for 30 to 60 seconds if you do swap devices (sometimes needed to reset it).

Seems the DHCP server does not work. Can you reboot the upstream device and confirm its DHCP server is on?

I don’t believe I have a modem in the conventional sense now that I check. I’m a university student and the device that provides internet to my room is an “Aruba 505H” access point. So I’m not sure how I’d go about turning it on and off as Hansome suggested.

Update: I slept on it and now when I connected the ethernet to the glinet, the DHCP magically started working again. Don’t know why it did, but hell, it’s a bloody start.

My problem now is that I still have no actual internet access. Chrome throws up a no internet message, and if i try to run a ping test to it always times out. Anyone have any solutions on this?

Try to log into the Aruba 505h at with admin for the user and the serial number for the password.

During the power outage, perhaps it was reset and needs to be reconfigured by the Uni IT dept or you may be able to verify settings with another roomie/neighbor.

It sounds like the Aruba is not connected to a network now.

I tried, but it didn’t work. I can’t access the admin panel. The wifi is set up by the university so i assume it’s all locked down.

My WiFi comes from the Aruba access point and that’s working just fine. I don’t think it’s a problem with the Aruba itself


I tried something crazy. I have a spare router, and decided to connect that router to the Aruba. Then I conneted my spare router to the Glinet’s WAN port and now I have internet access.

So it seems there is no technical problem, the glinet and aruba works fine. Something is stopping the Glinet from accessing the internet when directly connected to the Aruba

Could it be the mac address?

You can try clone your old router’s mac address to Mango and test.

Hi, I have the same issues with the WAN not working when I switch a router. I have to reboot my X750 to get a connection. Does anybody know a solution? This is very frustrating :confused:

More info needed and start a new thread instead of hijacking this one.

@shivadow Thank you for your suggestion. Here is a separate post:

I am looking forward to your help :slight_smile: