GL-MT300N-V2: Cannot connect to WiFi "Join wifi failed! (code=-5)"

Hi everyone,

I just got the mango router and I cannot get it to connect to my wifi network. This is what I see in the log: : [  615] gl-sdk>> bIsSaved=0, ssid=xfinitywifi_HUH_Guest, encryption=none, 
bssid=70:D3:79:E9:5C:80, wds=0, device=mt7628, identity=, channel=11 : [ 2022] gl-wifi-core>> bIsStaEnabled=1 : [  621] gl-sdk>> wifi_join return=-5 : [ 1422] gl-wifi-core>> Restart wifi...
daemon.notice netifd: Network device 'ra0' link is down
daemon.notice netifd: Network device 'ra0' link is up : gl_health start-> : [ 2022] gl-wifi-core>> bIsStaEnabled=1 : [ 2574] gl-wifi-core>> Join wifi failed! (code=-5) ***

A bit of background on what I am trying to do:

I live on campus housing where internet is provided by a single wifi network for all the units (managed by xfinity). I want to have iot devices in my home but using the available wifi means my devices are accessible by everyone on the network. I want the router to make my private network for my devices.

To access the internet I have to enter my details on a captive portal. Once entered, the device is registered by mac address and will be automatically allowed in further connections without having to input any credentials. I can also access an admin page where I can whitelist mac addresses manually and such devices will never see the captive portal.

I have tried everything on the documents here and they work on other networks, including a public xfinity hotspot. But on my home network the router just does not connect in any way.

Currently I am going around this problem by tethering with a spare android device which connects just fine. But it would be nice to get rid of that extra step in the setup.

I have also tried a tplink nano router and that one doesn’t connect either. This points to a more general problem/clash between the network and router firmware. The xfinity support center says they don’t actively block routers but they didn’t offer any help in configuring it.

I hope someone has some insight on how to fix this. Thanks in advance!