GL-MT300N-V2 - Cannot switch to AP mode

firmware: 3.102

Same problem as described here: AR750 - Need assistance setting up Access Point mode - #29 by alzhao

When I check Access Point mode and click on apply I receive this error:

“WARNING: No cable is plugged into the WAN port!”

WAN port is connected and it has valid IP address in static mode.

I also tried to set it to obtain ip via DHCP but I’ve got the same error. In the “INTERNET” page it says that wan port is connected. I think it’s a bug or i’ve got a faulty device.

In router mode it works very well (no problems on WAN port).

1 Like

I would need someone who has the same model, set the AP mode, make a backup of the configuration and share it so that I can upload it to my device and force the configuration.

It should be a firmware problem. Let me ask for a new firmware for you to try.

ok thanks, let’s hope the developers can pinpoint the problem

I also continue having problems with access point. Firmware 3.105, ar750. I basically want the device to work as a network switch behind my router.

Devices are connected via cat cable in the LAN ports, the router - facing cable is in the WAN port (the equation doesn’t seem to change if I connect that cable to a LAN port as well, though)
Right after switching the device to AP, no connection whatsoever works : device can’t even be pinged. My devices pull DHCP issued addresses in the 192.168.178.x subnet and can’t reach anymore.

Also, with static address in the 192.168.8.x subnet, the ar750 cannot be reached. Only firmware reset helps which is hardly optimal.

I was able to successfully set everything up.
Write-down for everyone else, including pitfalls I identified.

Use case

I want the ar750 to bridge connected devices to the rest of my home network. I identified “Access Point” network mode as what should serve my intent.


  • AR750 has Firmware v3.105.
  • Modem: Fritz!Box 7590 with default settings, DHCP assignment etc.
  • The modem sits at
  • AR750 gets assigned in that subnet. In the default network mode, it seems to bridge everything into the 192.168.8.x subnet. This works but e.g. won’t work with mdns of the 192.168.178.x subnet which is a problem already

AP approach & analysis

Upon entering AP mode, I encounter the situation described in above post 2h ago. More details:

  • My router tells me the AR750 is assigned
  • My test client device is connected via LAN port and shows that it is assigned, with as DNS + AP. Here lies a pitfall: my device still thinks it sits in the 192.168.8.x subnet. This must be resolved on my side. I was able to do so via disconnecting and reconnecting the LAN connection, please not that this means in the system settings. Disconnecting the LAN plug in itself probably won’t work on it’s own. More technically, the system has to refresh its DNS lease, in the process of DHCP network reconfiguration. Try different methods for achieving this. For WLAN, I suppose one should “forget” the AP + set it up again if you’re on a smartphone or something.
    • The ar750 software actually points this out to the user. I imagine, a direct How-To on setting up the connection on client devices again could be useful, as it appears the device is bricked until then.

Alas, everything works as intended now