GL-MT300N-V2 can't switch off default wifi while using WDS

I am setting up this router as a bridge for a printer that has ethernet but not wifi. So the router is configured to join my existing wifi as a client, the printer plugs into the LAN port, the router is set to WDS and forwards DHCP requests etc to the DHCP host on my LAN.

To everyone else, it looks almost like the printer is directly connected to the wifi/LAN.

The problem is that the router keeps broadcasting the default wifi network. If I switch off the network in the settings then the router is “bricked” because it doesn’t use the radio anymore at all… So it can’t join my wifi, so it doesn’t get an IP, so it’s unreachable to re-activate the wifi. I have to hard-reset it every time it loses power and reconfigure it from scratch.

Why isn’t there a setting to disable broadcasting a wifi network from the router IF it’s in WDS mode? I don’t want a GL-MT300N-V2-a01 extra wifi network, I just want the router to bridge ethernet to my existing wifi. Yet I have no way of turning off that default wifi network in WDS mode. All I can do is rename the network and change the password, but it’s still a full AP that gives a potential way into my network.

Running v3.105.

This is fixed since 3.201.

3.201 stayed in beta only

Unfortunately I can´t use 3.203 with my gl-mt300n-v2, WiFi slow and can´t connect to my SSID as it has a blank.