GL-MT300N-V2 often fails to rejoin WiFi when in WDS mode

I’m using this router as an ethernet to WiFi bridge. So on the LAN plug, I have an HP printer plugged in, and the WAN plug is empty.

I set it to WDS to connect to my home WiFi.

On a good day, it works. On a bad day (or often after losing power/WiFi), it’s a nightmare: it won’t reconnect to the WiFi ever. The only “solution” is to reset it and reconfigure it from scratch. This gets old very fast.

I tried firmware 105 and 203. On 105, it reconnects some of the time but I can’t switch off the default WiFi network it broadcasts or I lose ALL WiFi. On 203, it just refuses to reconnect to the WiFi most of the time and has to be reset.

I noticed that I’m getting slightly more success disconnecting the power, unplugging the printer from the LAN, rebooting the router, waiting 3 minutes, reconnecting the printer.

I cannot express how frustrating this is. Every time I have to deal with this, I want to throw the ****** thing into the wall. Please advise.

  1. Do you have a fritz box? Then try to switch off “autochannel” for 2.4GHZ there.
    In WDS mode the GLInet router only can reconnect to the same channel it was connected initially.
    So if the host router is changing the channel, GL-MT300N-V2 will not be able to keep the connection.

  2. Also search google for “openwrt-mt300n-v2-3.201-0402” firmware or send me PN.
    Unfortunately it´s not on the GLInet servers anymore.
    It will fix the bug that after powerloss the GL-MT300N-V2 will not reconnect if in WDS mode and if GL-MT300N-V2 WiFi AP is off.
    Any firmware after 3.201 also fixes this but made my cry when needing WDS purposes.

I am on 3.201-0402 and happy with it for WDS, only problem is that I need to switch off autochannnel on my FritzBox.

I think the WDS problem should work in 3.211 GL.iNet download center

I have a Unifi AP, and I don’t want to disable autochannel just to accomodate this defective device. I’ve also tried the 201 firmware in the past but it didn’t work properly either. 211 shows as snapshot/unstable… Seeing the performance of the “stable” firmware, I can’t imagine what snapshot/unstable means.

I gave up on it, I’m throwing it away and replacing it with something that actually works.

All my problems with Mango are gone since 3.211.
I am using it in WDS mode.
Thank you @alzhao.

Only thing I additionally had to do to avoid problems was to set Country and Region on Mango to Germany, as German AVM routers also are allowed to use channel 12+13, which is default off on mango.

I did this via console:
uci set‘DE’
uci set wireless.mt7628.region=‘1’
uci commit wireless

1 Like