GL-MT300N-V2 does not find the 3G/4G Alfa U4G Modem by itself

Hi, i bought the router together with a Modem for outdoor useage wich is the Alfa Tube U4G as a 3G/4G UMTS Modem. I started and initialized the Modem by connecting with Laptop direct via USB. for itself it works fine. as i tried to setup the router with the modem, the router does not recognize the Modem as i plugged it in via USB.
Is there an option to force this by any procedure?
I startet the openwrt-webapp and tried to add an extra interface, but nothing changed.
If anybody could give me a hint where the problem could be, im glad to hear about.

It may need a driver, or may not be compatible. Can you look up what is the modem chipset?

I do not work for and I am not directly associated with GL.iNet

thanks wcs2228 for your responce.
i got some information on this fact from the distributor:
chipset: qualcom MDM9200

You can try installing the kmod-usb-net-qmi-wwan package. There may also be other related packages.

I do not work for and I am not directly associated with GL.iNet

Hi i ve already installed a bunch of packages which refer to this an rebooted the router i guess i ve to configure something, what i didn know.
I tryied to find out on the side alfa-driver refers to, to find any driver to install on the router but on this fact i stuck.
the cat … give me these scene on the devices allready installed on the router, and especially the qualcom one has no driver see.

T: Bus=01 Lev=02 Prnt=04 Port=02 Cnt=01 Dev#= 6 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=05c6 ProdID=f000 Rev= 0.00
S: Manufacturer=Qualcomm, Incorporated
S: Product=Qualcomm CDMA Technologies MSM
S: SerialNumber=1234567890ABCDEF
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

how can i fix this by installing or configure what?
Thanks for some support in advance.

Unfortunately, I suspect the ALFA Tube-U4G is not a compatible. OpenWRT has limited availability of drivers for USB modems and GL.iNet has a list of tested modems somewhere on their website.

I see that there is an updated ALFA Tube-U4G V2 model that has the Quectel EG25-G modem chipset, which is used in some GL.iNet LTE routers and is more likely to have an OpenWRT driver. Huawei HiLink host-less USB modems are also more likely to work.

I do not work for and I do not have formal association with GL.iNet

thanks for your advices i will invest in a other setup.