GL-MT300N-V2 does not respond after firmware update

Good day everyone, I hope someone can help me.

I purchased a GL-MT300N-V2 and it was working fantastically with OpenVPN, it was just what I needed. However, I then used the router control panel (accessed by to update the firmware to 2.27. The firmware downloaded fine, and according to the control panel it installed fine also. The router then restarted but has become unresponsive. I can’t even ‘press and hold’ reset to restore factory settings. The lights come on, but no internet access, and I can’t access the control panel (

Can anyone help me?

Thank you in advance,

Have you follow the procedures to upgrade your firmware?
I used to face the same problem after upgrade firmware because I selected keep current settings when I upgraded it.
Maybe you can try to uboot your router to drbrick it. Here is a article for your reference.

I have the same problem.
I bricked it by trying to flash: gl-mt300n-v2-3.012.bin

I tried deBricking it by following this page:

I tried the following bin files:

  • lede-gl-mt300n-v2-clean.bin
  • gl-mt300n-v2-3.0-1011_clean.bin
  • lede-mt300n-v2-clean-2.264.bin
  • lede-mt300n-v2-2.26.bin

…Still doesn’t boot.

  • My ethernet adapter can’t find an IP.
  • going to the address ( doesn’t work (obviously)
  • The 1st green light is the only light that comes on.

Can you just try 3.012 from

Don’t try everything else.

You do get to the Uboot GUI, right?

Yes glitch get the Uboot GUI, that is how I keep loading all these bin files.
Thanks for the reply

I tried loading this bin with the Uboot gui. Still nothing. By the way this is the bin that I started with which I loaded on the normal gui.
Thanks Alzhao

[[[ SOLUTION ]]]
FYI…Make sure you have a GL-MT300N-V2 and not a GL-MT300N
I did NOT have a V2, so it would start up.