GL-MT300N-V2 - Firmware 3.216 - Installing tor

I’ve GL-MT300N-V2 with Firmware 3.216.
I refreshed the plug-in list before doing this.
I tried to install Tor from the plug-in page, I could only find the “tor” plug-in, and I installed it.
I can’t find the “gl-tor” plug-in, so if I open it say “Warning: The API isn’t available!”
I also tried to install the “tor-geoip” plug-in, as I see that it was installed in the “firmware beta 3.215 with tor included”, but it says that there isn’t enough space.


  • how to install “gl-tor” plug-in as it isn’t available in list?
  • if “tor-geoip” plug-in is important, how to get space to install it?

I see there that you advise to remove other packages as openvpn to get space.
Good, but still the “gl-tor” plug-in isn’t available in the list.

I tried to install the firmware 4.3.7 release4, and here I can find all the plug-ins, as the “gl-sdk4-tor”, but I can’t install it because there ins’t enough space.
I tried to remove the openvpn/ovpn packages but it gives me errors, as it seems that removing isn’t supported. Maybe it is a problem on the firmware…

So, which is the best and last working firmware to get Tor working on it? Is it really the firmware beta 3.215 with tor included?

You cannot realy remove package and release spaces. It is read only file system.

What you can do is using plug a usb disk and use exroot to extend the system.

1 Like

Thanks, I’ll try this.

unfortunately in order to use an external drive it’s necessary to install some little packages (block-mount kmod-fs-ext4 e2fsprogs parted) and there’s just 40k free… I tried this procedure [OpenWrt Wiki] Extroot configuration… How can I solve it?