GL-MT300N-V2 - firmware failed to flash

After a password issue (I forgot the password) I tried to reset the router following the 10 seconds reset rule. Unfortunately after that the router becomes unresponsive (blinking power LED)

I tried to Uboot and upload the latest firmware (also tried other versions, all with the same results): I got the Uboot page, selected the file, upload, get the update in progress confirmation page, and after some time, the router resets by itself and the power led star blinking again (pattern is green solid, green blinking, and repeats)

I do not know if is a problem with the process that I’m following or with the router.

Is any special meaning for the LED pattern light that I’m getting?


It sound like you interrupted the reset process will blink for 3-5 minutes

The debrick has some information on light flashes
Sometimes the wireless locks to 2.4ghz or 5ghz I have also exprienced needing to try all the ethernet LAN/WAN ports to access the router. Router also goes back to default IP of (Sometimes there is a conflict)

Thank you. I’ve read those links before, and do not apply to my case.

I’m trying to determine if the flash is incomplete/complete, successful or not. The only thing that I got is this power led blinking with these two speeds (faster and slower).

Best to go by lights not time.

To reset. Have the Mango powered up, press and hold the reset button, the middle Led will blink about 5 times, blink even faster about 5 times then blink really fast at which time you release the reset button. The unit will then reboot.shoukd be available via LAN or WiFi at

To get to uboot you disconnect Mango from power, hold in the reset button and insert power cable When the left and middle LEDs are solid release the reset button. Should be accessible at via LAN with your device set to 192.168.8.x

Thank you. Yes, I did that from the first time. The problem that I have is that the Uboot process is apparently ok: I select the file, upload, get the ‘in progress’ page, and the router red light start blinking, then the middle and red light blink, then the router seems to reset. The green power light comes on, solid, and then later start to blink slow and fast, go back to all off, then the cycle repeats.
That was my first email meaning.
Do anybody can help me please?

From what you described, uboot process goes fine.

Which firmware did you flash?

Also change one power adapter and see.

Firmware flashed: openwrt-mt300n-v2-3.211-1227.bin
I changed the power adapters

  1. 1A@5V
    Computer used to flash: macbook pro MacOS 10.15.7

Still no success.

seems everthing is fine. So the router has problems.

Have you ever damaged the radio data for some reason? When radio data is damaged the router will crash once it wants to enable radio.

If you have serial connector you can open the case and connect to the UART pins to find the exact problem.

I do not have an UART adapter.
I did not mess with the radio, all was as it was. I never open the case or anything like that.

What’s the UART procedure? Do you have a link to it?

(I still wonder how much the adapter will cost)

Like this UART Serial - GL.iNet Docs

Ok. I ordered one. I will try when I got it.

Thank you alzhao.

1 Like

Are you flashing the firmware over a wired, wireless connection, USB or Micro SD? If you are doing it wirelessly that could be the problem. Best to do it hardwired to the device. (I only ask cause no one did and limbot alluded to it in the reset uboot process)