GL-MT300N-V2 (mango, mini smart router) is not connecting to internet

Hello, new user of the glinet router here. I set up my router about a week ago, and ignoring some issues with the VPN, it has been working fine. I left for trip to my home city and was gone for about 3 days, when I returned the router seemed fine but the internet just. Doesn’t work.

It accepts the connection to WAN, even providing IP etc. But internet just doesn’t work - chrome will say “cannot connect to DNS” before eventually coming up with the no internet error, my phone will just say no internet. I am at my wits end with this - I resetted the router, the firmware, everything. It is not a problem with the WAN cable, i connected with a second spare router and wifi / ethernet on that works just fine.

Screenshots provided of the relevant screens

Any idea on whats wrong?

You can check if it is a DNS problem by trying to open in a browser or ping, using an IP address instead of using a domain name.

If that works, then try manually setting the DNS IP address on your computer or phone to (CloudFlare DNS). If that works also, then the problem looks like your main router at IP address

I do not work for and I am not directly associated with GL.iNet

Did you try suggestions from @wcs2228