GL-MT300N-V2 (Mango) Repeater Mode Instability - FIX

Hi Guys,

For the past couple of days I’ve been trying to troubleshoot an ongoing issue with my Mango when configured in repeater mode; I’d get it to connect to my home network and then relay/repeat it for my other devices, however I was finding the connection would constantly flap between the Mango and my upstream APs (Unifi NanoHD’s). It was to the point sometimes where it was near unusable and was even non-responsive via the web interface. Latency when pinging through the device out to the internet was all over the place, speedtests often would run at 0.2-0.5Mbps (on a 100Mbps link), it was just generally not healthy.

After playing around with a few settings trying to find what the issue might be, I discovered that by changing my home WiFi network (that the Mango is configured to repeat) to have its channel width be set to HT20 for 2.4GHz, the issues immediately went away. Latency is back to where it should be, throughput is up heaps, and the connection seems to be significantly more stable + the management interface of the router is much more responsive.

So for anyone else out there like me who is having the same kind of symptoms, I’d suggest setting your channel width to 20 instead of 40 for 2.4GHz. I’m curious if this is a known issue or if anyone else has seen it before?


Where I live I can see several other WiFi stations on the 2.4 GHz band. I have found that a wider 40 MHz channel on the 2.4 GHz band just ends up competing more with these other stations, ultimately noising up the channel with retries and fallbacks, resulting in poor performance despite the larger channel width. Personally I would not imagine configuring a 40 MHz channel width on 2.4GHz unless I was placing a single access point in a rural region with no other stations in sight… regardless of the brand of equipment.

1 Like

As @Stand said, when you use 2.4G, it is better to use HT20, which is more stable.

Forcing on HT40, may be desired by some people because they want to see their wifi working on 300Mbps. It could cause issues if you have too much interference.