GL-MT300N-V2 no bridge mode for WLAN + WAN + LAN

Hello,
I want to use my GL-MT300N-V2 as a Bridge betwen WLAN, WAN and LAN. The WAN port is set in this case to LAN mode. All connected devices are part of the same network and should see each other. I’ve found no adjustment solution, not in the GL-MT web interface and not in LUCI. All settings in network in section interfaces or in section switch do not work.

Reason is a small network setup with a development PC and two programmable logic controllers which share some data. Doing it with the GL-MT300N-V2 would be fine, because of its size and it is a single device.

I use the firmware “openwrt-mt300n-v2-3.102.bin”

Thx for your hints and help

Can you simply set the WAN as LAN?

Yes, setting WAN to LAN is possible. In this case both devices are accessible from the PC via WLAN, but the devices on WAN and LAN ports cannot communicate among each other.

Not sure how to solve. But this is generally a vlan problem.

I think I’ve solved the problem. Network stability seems to be ok. My both PLCs and my programming PC can communicate now and that was all I want.

  1. In the GL.inet Web interface set the WAN Port to LAN
  2. In the GL.inet Web interface open in More Settings/Advanced the LuCI Web interface
  3. In the LuCi Web interface open the Menu Network/Switch and disable VLAN functionality
  4. In the LuCi Web interface open the Menu Network/Interfaces
    4.1 In the appearing page go to Tab LAN and select Physical settings
    4.2 In the physical settings select the option bridge interfaces
    4.3 Select the interfaces for bridging: “eth0”, “eth0.1”, “eth0.2”, “ra0”, mt7628.network1…"

ra0: is the WAN port
mt7628.network1…: is the WLAN
eth0: is the internal switch
eth0.1 is VLAN 1 setting
eth0.2 is VALN 2 setting

Don’t ask why I had to select the VLAN 1 and 2 settings, but without it didn’t work although VLAN was disabled…