GL-MT300N-V2 Not connecting to hotel Wi-Fi

Hi All,

I got the 300N to use when away form home and staying in hotels, this week it’s Spain.

Tested the 300N at home and it worked well, very easy to connect to the home Wi-Fi and Laptop connected straight away (Windows 10 1909), used it like this for about a week before setting out for Spain. I also have a device that is cable only, the real reason for getting the 300N and that worked straight away when connected to the LAN port.

At the hotel the Laptop and mobile phone work fine, they get an IP and then display the hotels captive portal, enter the details and internet access.

The problem appears to be that the 300N does not get an IP address form the totel Wi-Fi. If I hotspot the mobile phone it works with phone no problem, just like home. The only difference appears to be that the Hotel has multiple hotspots. The Wi-Fi analysers on the phone shows 8 all with the same SSID.

If I use the USB to connect the 300N to the phone and tether using Wi-Fi on the phone to the Hotel Wi-Fi it also works, but this does not help the cable only device.

Does any body have any suggestions as to what the problem could be?

I’ve here for the next 3 night so can test any suggestions

1 Like

What is the hotel name? Mariott groups hotels have some problems with the router repeater set up.

Have you checked this guide Connect to Captive Portal - GL.iNet Docs

Hi alzhao,

I’m in a Hotel that is part of the Hoteles Andaluces Con Encanto group.

I did try the link but it didn’t help. I think the problem is that I don’t get an IP address so I’m not even gettign as far as the captive portal.


I have had a very similar experience in a hotel in Spain a while ago and never really got to the buttom of it or found a solution despite others trying their best to help with various suggestions: