GL-MT300N-V2 not working and showing only 1 light

I recently bought a 300M Mini Smart router.
Model: GL-MT300N-V2
After uploading files and updating the firmware it now is stuck on 1 solid light and I cannot access via the IP address.
I pressed reset button and nothing changed, still just the 1st light showing once powered on.

What is the best way to resolve this, do I need firmware or is there a solution.

Thanks in advance.

I followed these steps.

  • I connected computer to lan, held reset and then plugged in power cable and third light flashed and now the 1st two lights are showing.
  • I then changed my computers IP address to the one in the video
  • I tried to go to then on 2 browsers and it says ‘site cannot be reached’

Any suggestions?

did you change your computers ip address? read the directions very carefully. It took me a while but now it works smoothly.

Thanks for the reply.
Yes I changed it to The IP address listed In the video (see my update post)
Were you receiving the same issue?

what firmware did you flash? Pls let me know and I want to check if it is wrong fimware.

About uboot web failsafe mode, seems what you are doing is correct. But I need to make sure you did everything correct. There are several things easy to mess up:

  1. Need to plug in Eth cable before powering up.
  2. Keep the reset button pressed. One LED will flash once per second and wait until another LED light up.
  3. In your updated post, you didn’t state that you changed the IP of your PC to Pls make sure.

If possible, make a video.