GL-MT300N-V2 Only OpenVPN Server and LAN

Hi. Im trying to configure my GL to use as a OpenVPN server inside another network. The network is and my GL is configured with with their mask and Gateway. The two ethernet ports are configured as LAN. I up a OpenVPN sever and works, i can connect from outside and enter in the IP WEB to change parameters in te GL.

My problem is that i can’t access to no computer in the internal network If i use the NETWORK->DIAGNOSTICS inside the router, i can use ping, and arrive to for example answering my request, but from the PC that are connected to the VPN server i can’t arrive to the same PC.

And i believe that when im connected to the OpenVPN server, i have not access to internet…

How i have to configure my GL in order to inert to another network, configure only the IP of the GL, and up one OpenVPN Server to access to these network?

Please check the route on the VPN Client to confirm that it will forward packets destined for over the VPN. You can use tracert and route PRINT command.

Hi. I paste the information below:

I check again the ping from the server and is Ok, but i can’t receive answer to the ping from my laptot. And i confirm, when im connected to the VPN i don’t have internet access…


I compare the route print with another of my good connections and is the same…(i configure the same OpenVPN range) so i believe that the problem is in the interfaces definitions or routes configuration of the router…
The principal difference of a normal configuration is that in a normal configuration you have WAN/LAN and configure the OpenVPN that out by WAN (i suppose) but in this configuration i unable WAN connection, and use the two eth ports in LAN, and the VPN too… may be i forget something whe configure interfaces or firewalll…i don’t know.
My order of configuration was, i putted WAN as LAN in the admin panel. Then i configured the OpenVPN server (route mode and sharing files) and finally i put in the LAN Interface the IP that i forwarded in the real network that out to internet:

Please try turning on “Access Local Network” on OpenVPN Server page,

These option was enabled. I try disabling and check the ping, and enabling again and check ping but nothing…

I guess previous settings may make things complicated, could you try setup from scratch? Only “Access Local Network” is needed I think.

Hi. But if i configure from scratch i have to unable WAN access because only need the two eth ports as LAN access. So i have to put a IP in the LAN configuration and then enable the VPN, the same that i did…
There are some thing in te routes of the server that not redirect that arrive from VPN to LAN or, may be is doing it but when receive the information of the LAN, not redirect to the VPN…this case is more probable because the normal way i going out by WAN, and WAN is unabled…How can i check if the packets that receive from LAN are redirected to VPN using LAN, not WAN?

May be somebody can send me a backup for the router mango with the configuration that i would like in order to check the differences.
I would like that the router works as a VPN Server device inside another network…So i suppose that not need WAN connection, only LAN, so the LAN connection have to go out using his gateway. And the OpenVPN Server have to use the LAN interface to go out to internet (in order to use the external network).
Because i have the devices that i would like to access in the same network…

Here’s my mt300n-v2 configuration backup. I installed luci, started OpenVPN server, and enable Access Local Network. (33.8 KB)

Hi hansome, but Do you use LAN to access to internet? because i wouldnt like to use WAN to access to internet, only would like to use LAN.
The backup have the DHCP disabled (i need to disable it)? What IP are configured ?
The user/pass is root/root?