GL-MT300N-V2 remote access issues


I have a GL-MT300N-V2 and tried to setup remote access through ddns.
I keep getting directed to my modem/router that the GL-MT300N-V2 is plugged in to.

I disable VPN when i try to connect remotely other than that I haven’t tried anything like port forwarding because I don’t know which ports to open.

I’m trying to update my openVPN files remotely from time to time because I travel a lot, any help would be appreciated.

What are you guys trying to forward?

If you want to log into the router remotely, i would recommend only SSH. SSH lets you do Client to Server forwarding like so:

ssh -L 8080:localhost:80 root@<your_ddns_url>

That will let you access http://localhost:8080/ on your browser after you establish a connection via SSH, to get the router UI :slight_smile:

To do that enable SSH Remote Access from the Dynamic DNS page.
You also need to port forward TCP port 22 in your upstream router if you have one.

For OpenVPN you want to port forward UDP port 1194.

Sorry I thought I had found a solution that’s why i deleted my previous post :sweat_smile:

Yes so I’ve done everything you mentioned but every time I try to establish a ssh connection it either refuses the connection or times out.

Any suggestions?

(I turn off my VPN when I’m trying to connect)

Well i can still see the post you removed and yes, you just need to remove that file it wrote:


Remove it and try again. That warning was because once you connect to a host for the first time it will save the devices key. If you then for example reset your router, a new key is made. When you then try to connect, the keys are different and that is the warning.

yes that’s why i removed it because I sorted that out and the problem still persists :sweat_smile:

Are you on Windows?

For Windows you can download Bitvise SSH Client from here, its free:

If you go to the C2S tab for a connection, you can setup all the ports you want to forward.

Oh wow, brilliant, I’m gonna give this a try tomorrow. I’ll keep you guys posted! Thank you very much for your help @Johnex :+1:

As a bonus. You can create a poor mans VPN using Bitvise SSH Client and another program. Unfortunately the other program is not free.

In the Services tab you can see in the screenshot above, you can set up a Socks5 proxy that will forward via the SSH connection. Using a program called “Proxifier”, you can then route all windows traffic into the proxy and out the other side of the SSH connection :slight_smile:

Here is a link:

Oh god I’m such an idiot. I only have my Mac with me right now, any chance there’s a similar prog for Mac? or am I hoping for too much :sweat_smile:. Again thank you so much for your help. Cheers

Well i did a quick search and seems like it’s harder on Mac. All the clients i found are broken for the latest macOSX versions :frowning:

You are stuck with the ssh command from a few posts back :frowning:

Open the Terminal app under macOS (⌘-space for Spotlight search is the quickest)


Enter the ssh command. Cursor keys and delete can be used to edit.

Once you’ve entered it once, up-arrow will let you go back in your history and return will re-execute the line. ctrl-r (^r) will also let you search through your history in the terminal window, so, for example ^rssh will likely bring it up again. ^r again will search back even further for things that match “ssh”.

thanks a lot both you, I’m away for work but I have a laptop at home. I think I’ll do what @Johnex suggested once I get back and update you guys on how it goes! :+1:

hey guys,

@Johnex I tried the program and did what you showed in the screenshot, remote access is still not working, I think I might try to do this at a friends house, perhaps my ISP is blocking port forwarding. If you guys have any more suggestions I’m all ears, otherwise I’ll keep you guys posted about what happens :+1:
Edit: FYI just in case there’s some confusion I’m trying to establish a remote connection to my mango v2 from a different connection. like from a different country

It is clear for me what you are trying to do.

Hmm. Could you check the dropbear ssh config on your mango? It might be different defaults than my S1300.

Do cat /etc/config/dropbear for me please :slight_smile:

root@MT300N-V2:~# cat /etc/config/dropbear
config dropbear
option PasswordAuth ‘on’
option RootPasswordAuth ‘on’
option Port ‘22’

option BannerFile ‘/etc/banner’



Yeah :slight_smile:

Hmm strange. The config is ok, it should work. I guess somewhere they are blocking port 22?
Try changing to port 2345 instead?

Nah man the box is connected through ethernet to a modem router and I think the ISP is blocking it, so I’m gonna try with a few other ones to see if that’s not the problem, thank a lot for your help though