GL-MT300N-V2 - showing only one LED and failed to flash firmware

I just bought a GL-MT300N-V2, at the first plugin, everything works well. After I set the admin password, I tried to plugin a Ethernet cable on Wan port. And I do not have internet access, I tried to unplug the power cable, and when I replug it, there was only power LED on.

I tried to do a reset, and I cannot see the blinking that should appear.

I tried to refresh the firmware several time, with all different firmware that I can find on the download centre for this model. All the time, the right most LED start to blink for a while, and then the right most LED and middle LED start to blink together for a while. And right most LED and middle LED went down for about ten second. And the right most LED flash once, and all three LED went down for about one second, and the power LED was back, and just stay there.

I do not know if is a problem with the process that I’m following or with the router.

Is any special meaning for the LED pattern light that I’m getting?


For a reset you need to boot up the router and then hold the reset button. The middle LED will flash about 5 times, then flash faster 5 times then flash even faster at which time you release the reset button .

Youtube video here

It may be you need to uboot a firmware back on
Remove power
Hold down Reset Button
Insert Power
Left power button will turn on and Middle LED will flash 5 times and then go solid
Release Reset