GL-MT300N-V2 slow in repeater [FINISHED]

Hi there,
when I’m using the MT300N-V2 (firmware 2.271) with internet over LAN in the WAN port the internet speed is ok about 30 to 60 mbit/s download and upload 20 to 40 mbit/s ( it varies a lot), I have 100 mbit/s Internet connection, and via LAN I get 85-95 mbit/s.

But when using the repeater WISP mode and connect it to my Fritz!Box I only get about 3 mbit/s donwload and for the most part just a few kbps upload but sometimes 1 mbit/s.

In Wireless settings, the Power slider is on 20, and I’m using psk2 encryption

My WIFI from me Fritz!Box is fast, 85-95 mbit/s internet is no problem, and it can even be faster intern between devices.

Why does it happend, am I the only one?

best regards

The commend with the answer to fix the problem:

1 Like

do you live in high density housing area? lots of other people around with 2.4GHz wifi equipment?

I noticed when in typical central European flats everyone has 2.4GHz equipment and there is a lot of interference from it all resulting in very poor performance. load wifi analyzer on an android device and look at your surroundings to pick the best free channel. although most of the 2.4GHz spectrum may well be very full already.

There are not a lot of wifi near me, see picture


and the two router are litterly one and a have meter apart.
So there should not be a problem with connection to the other WIFI.

in your screenshot it appears you are not in wisp mode - is that right?

when you have it configured in wisp mode do you have the ethernet cable plugged in as well? if not have you tried rebooting the router after switching modes?

are you using vpn configured on the router?

what is the noise level on the gl-inet device to your upstream wifi device? you can find it in the wireless tab in luci here: – mouse over the connection quality indicator.

At the moment I dont have it in WISP mode, but internet over LAN in the WAN port and it’s own WIFI. In WISP mode I can’t use it because it is to slow.

When I tried to use WISP mode, i unplugged the LAN cable, I also rebooted it, powered it off waited for for the light to go off, waited an extra 5 second and connected it again with power.

At the moment I use VPN, I know that the internet is slower, but does it affect the WIFI?

I’m gonna connect as repeater again and gonna look at the noise lvl.

How are you testing bandwidth? You have tested without VPN enabled? With OpenVPN enabled max throughput might be around 6Mbit on the MT300N.

Also try switching to 150Mbit mode - a single 20MHz 2.4GHz channel is then used instead of 40MHz

I test it with Meteor (android internet speedtest app) and speedtest by Ookla. At the moment without VPN because the WIFI first need to work probably before I’m using VPN.

I needed to find my Laptop to go to the link, because I can’t “hover the mouse over” on my smartphone.

I know the to networks a connected because I can se the mini router in my main router, but there is someting wrong.

(Sorry that is gonne be 3 post, but I can only add on picture per post.)

I know that both WIFI are on channel 7, because I looked it up in both router, but the app (both, the one from last time, and now a new one) say that they are using a different channel.
For the purble network at the end there is 7(5) and for the orange there is 7(9). These are both mine. Purple is mini router orange/brune is the main router.

Here what my main router is displaying about the mini router:

I’m gonna switch from 300Mbit/s to 150 Mbit/s reboot and come back.

After switching to 150 Mbit/s this is the result:

Iperf3 between my smartphone and tablet is between 8 and 20 mbit/s

It doesnt look like that router has support for Luci to read the wifi information.

The stand out thing to me is your main router is saying the ‘actual datarate’ is 10Mbit/1Mbit.

I don’t own this router - but maybe if you ssh into it and run =iwinfo= you’ll get output like this

root@GL-AR300M:~# iwinfo
wlan-sta ESSID: “blah”
Access Point: blah
Mode: Client Channel: 7 (2.442 GHz)
Tx-Power: 20 dBm Link Quality: 51/70
Signal: -59 dBm Noise: -95 dBm
Bit Rate: 121.5 MBit/s
Encryption: WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11bgn
Hardware: unknown [Generic MAC80211]
TX power offset: unknown
Frequency offset: unknown
Supports VAPs: yes PHY name: phy0

wlan0 ESSID: “gl-inet”
Access Point: blah
Mode: Master Channel: 7 (2.442 GHz)
Tx-Power: 20 dBm Link Quality: 70/70
Signal: -34 dBm Noise: -95 dBm
Bit Rate: 94.8 MBit/s
Encryption: WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11bgn
Hardware: unknown [Generic MAC80211]
TX power offset: unknown
Frequency offset: unknown
Supports VAPs: yes PHY name: phy0

The stand out thing to me is your main router is saying the ‘actual datarate’ is 10Mbit/1Mbit.

I noticed the same and a really wondering why.
My smartphone has max 72/72 Mbit/s and actual 64/5 Mbit/s on 2.4 GHz

I don’t get really any information:

Just a lot of unkown

Don’t know what happend, after I changed 150 mbit/s to 300 mbit/s, now I suddently have faster network, my main router says actually 270/122 and speedtest by Ookla is also fine:

Looks kinda like he router had problems to change to 300 mbit/s and maybe was stuck in 11 mbit/s mode some how.

Thanks for your help!

Now when I look at the WIFI app, both network uses the same channel.

After a reboot of the MT300N-V2 the actual datarate was again back to 10/1 mbit/s, eventhough in the settings of the router was 300 mbit/s, so I changed the mode to 150M, and the actuale datarate got over 100 mbit/s. So I changed the mode to 300M and then i actual datarate is now up to 283/274 mbit/s.

So it lookes like, the router falls back to 11M mode after a reboot… That sucks, but at least I know now how to fix it.

Interesting. If you have the physical switch configured to do anything - try disabling it completely – see if it boots up ok.

I don’t have set the switch to do any thing. It’s set on “No funktion (default)”.

Also when I disconnect from an VPN the speed goes back to 10/1 mbps …

I ran into something similar with AR300M-lite and a second WiFi usb adapter. Every time I changed setting on usb adapter, main radio reset to 11Mbps. I thought the second adapter was causing it. Also settings under advanced settings did not match the settings (11n, g etc) in main web gui. I am running 2.27

When using the MT300N-V2 as wifi router and it gets internet via lan in it’s wan port, the wifi don’t change after a reboot.

Is there a way to make a bug report?