GL-MT300N v2 Tor and Wisp issues

I have a GL-MT300N v2 that I flashed with lede-mt300n-v2-tor-2.264.

I’ve run into a few issues.

  1. When I have a fresh image, I can’t get the router into wireless bridge mode (wisp). It seems the only way I can do this is if I reload the factory firmware, configure it that way, then load lede-mt300n-v2-tor-2.264 and keeping the configuration. Also, if I do a clean lede-mt300n-v2-tor-2.264 flash and scan for ssid’s, nothing gets returned.

  2. When I do get wisp working by the work around that I’ve figured out, Tor connection does come up as connected, but nothing gets routed via tor. I’ve tried this in wisp and hard wired directly to my modem. Tor connects but it doesn’t route. It’s not a firewall/nat issue.

I purchased this little box on the assumption that it was easy to get wisp and tor working. It seems to be just the opposite so far. All the guides I’ve read are useless and there aren’t any videos I can watch to help. I’m not completely useless, I am a sys/network admin. I really just don’t feel like taking the time to research and trial and error this. I’d like some guidance please. Thanks!

edit: If this is in the wrong section, mods please move…

1 Like

I agree with you wholeheartedly.

We’re running into the same EXACT issues so others must be affected by this as well.

The only difference between our issues is I seem to have gone a step past bricking the router. I honestly have no idea what’s wrong with it and I’ve followed all the instructions very carefully.

I have another GL router arriving tomorrow. The blue one. I have a good feeling that it’ll go much smoother.

Don’t keep settings when shift between different firmware.

I will test the tor firmware for v2 next week.

I’ve tried it both ways numberous times. The only way i can get for firmware working in wisp mode is to retain the settings.

Regardless, even when I do a clean install and plug the wan directly into my modem, tor doesn’t work. Some guides say there should be two ssid’s, but i only see one, “portal”, and plugging into the lan doesn’t work either.

Tor says it’s connected but nothing gets routed…

Thanks for your help alzhao

Edit: if i go into luci and scan for ssid’s it does find them. I get an error when trying to connect. I don’t have it here but give me a little bit and i will post the error.

Instead of flashing to the LEDE firmware… Why not just make a custom GL.iNet firmware, with the option of a TOR vpn? that would make things much easier…

I fixed some bugs today but still need to fix several other.

The reason we have a customized firmware is that we want to make it fully open source.

Thanks Alzhao, can you explain what fixes you’ve made and need to make? Just curious…

Also, I appreciate the opensource aspect of it, but sometime people want simplicity. If TOR was a part of the official GL.iNet, I think it would be a good seller. Just my opinion.

Thanks for your help!

I did some work but had no time to do more. It is mainly because of the WiFi driver difference

Hi Alzhao, how are you making out with the fixes? haven’t heard anything in about a week. Thanks.

Not too much progress. I bookmarked and will find time to do this asap.

I appreciate your efforts

Happy Monday, hope you had a great weekend. Just checking in… I purchased this about a month ago and still have yet to use it as intended due to lack of TOR functionality…

Thanks again!

My sincere apologies. I will report back on Wednesday.

Thanks, I really don’t mean to be a pain. You seem to be the only person working the engineering section of GL.iNet! That means you are a busy person, and I do appreciate your time and efforts!

Not really. I made the tor firmware so I have to fix it.

We have a bunch of engineers all of them are busy with something.

I’m sure… I was just being a bit sarcastic, since I see you responding quite a bit! Thanks!

Did some work today. Not finished. Continue tomorrow

1 Like


Finally, pls check GL.iNet download center and find v2.2641

You can flash this firmware directly from your old UI.

After setting up repeater, if Tor cannot connect, you may need to restart the router.

Also updated files in github.

1 Like

Looks to be working! WISP and TOR without any real difficult configurations needed on the users end! I will continue to play with it and report back any issues that I may find! Curious, what changes were needed that you made to get it working properly?

Thanks for all your help!