GL-MT300N-V2 Unable to connect to the admin interface

Hello,

I have just installed the version 4 on my GL-MT300N-V2 and now in router mode (192.168.8.1) and connected to WiFi network (192.168.1.1) I cannot connect to the admin interface using the IP address assigned by the WiFi network (https://192.168.1.30).

Any ideas?

1 Like

So the Wi-Fi network is a 192.168.1.0/24 while the router is still 192.168.8.0/24? Your routes are all f—'d up. No packets know where to go. Reset to stock.

If you want to setup a specific subnet, using anything other than 192.168.1.0/24. U-boot uses 192.168.1.1 for when things go really wrong.

Apologies I was not clear. i have my router WLAN (192.168.1.0/24) and the WLAN of the GL.iNet router (192.168.8.0/24) .
The GL.iNet an IP address in the WLAN of my router (192.168.1.30).
When I connect with my client device to my router (not the GL.iNet router) I now cannot access the admin interface of the GL.iNet; I used to be able to when using version 3. So now with version 4 when i connect to https://192.168.1.30 I get a time out.

Any ideas?

Thanks

1 Like

Apologies again - I can connect to the admin interface from the GL.iNet WLAN (e.g. when my device is connected to the WiFi of the GL.iNet I can access the admin interface @ 192.168.8.1). My issue is that when I am connected to the WLAN of my own router I cannot access the admin interface by typing the IP address of the GL.iNet router in that WLAN (192.168.1.30).

I used to be able to do do this (connect the device to my own router WLAN and then access the the GL.iNet admin interface via the IP address assigned to the GL.iNet by my other router) before but not since I installed version 4.

I also remember that in version 3 there was a setting to check if HTTP based access to the admin interface was to be allowed and another setting to have a static IP address - both settings seem to have gone from version 4: it may not have anything to do with my issue but it could be related.

You could make lan network range for gl router for example 192.168.20.1/255
Just not 0,1,8 because some conflict ip address from wan or WLAN.
For example my usb dongle 4G can not change static IP and lock only 192.168.0.1
Some guest lan network range, some other devices lan network range.

@slesar Thanks for looking into it - this is not related to my issue.

Are these two settings gone from version 4?

If you use your GL as some “AccessPoint” and don’t care about firewalling then, you can try to disable the firewall by accepting all packages from everywhere:

Are you sure you’re running in router mode? Then how did you connect your MT300N to the WiFi network?

Yes Router mode with the internet coming from a WiFi network broadcasted by my router.

Then how did you connect your MT300N to the WiFi network? Did you have on your modem modes similar to these:

If yes, which mode did you select?

OP, I believe there is a mistake in terminology. 'WLAN" = “Wireless Local Area Network”. You indicate you connect to a different router. Presumably this is upstream from the GL device (eg: $upstreamRouterLAN → $glDeviceWAN).

Are you looking to be able to manage the GL device while you’re connected to your other router? If so the first thing is to set a DHCP Reservation/Static IP on the upstream router to the GL device.

Consider diagramming your topology for us:

Thank you @bring.fringe18 - yes that is exactify what I am trying to do. In my upstream router I already have a static IP. I used to be able to do this while the router was on version 3.x but now on version 4.x I cannot do this anymore as I get a time out.

So it appears to be a change from one version to the other.

Would anyone be able to confirm if this is an expected change?

It looks like it was cut after firmware 3.16 as far as I can tell.

If you know for certain the GL device will never be directly connected to Public Internet/ISP’s WAN I’d just open a Port Forward rule fr WAN to the default GL GUI IP 192.168.8.1:443. (GL GUI → Network → Firewall).

If you need higher security than that we can discuss setting up a WireGuard VPN solution provided your upstream router supports WG.