GL-MT300N-V2 USB tether bridge to ethernet?

I just picked up a GL-MT300N-V2, such a powerful little router in a tiny package! I’m tempted to grab one more to play around with, and a spare to keep in my bag as a valuable networking tool… lol

Anyway, Here’s my question… I have a Netgear Unite Explore 4G LTE modem/hotspot which currently serves as my main internet connection. (rural area with good coverage) I’ve found that I get much better speeds with this modem when tethering via USB. Initially I bought a router that advertised USB tethering as one of it’s features, with plans to tether the LTE modem directly to the router. (I bought cheap Asus RT-N66U) Unfortunately there was issues with that router and I was unable to use it in that configuration. So I decided to get the GL-MT300N-V2 to tether the modem to, and then plug into the WAN port on my router. This works great! Everything works without issue and I’m getting the sames speeds on the internet as when I tether the modem directly to a PC.

What I want to do, if possible, is set up a bridge in the GL-MT300N-V2, so there’s no routing or NAT happening there. I would prefer it to be “transparent” even, so the main router sees the LTE modem on it’s WAN port, instead of seeing the GL-MT300N-V2. I’m not very well versed with OpenWRT, and didn’t see any way to do this in the GL.inet interface. I poked around in LuCI a little, but didn’t want to “break” anything so I thought I’d ask here.

FYI, I did search around a bit and couldn’t find an answer in these forums, so if it’s already posted, my apologies for asking again. A quick link to that info would be appreciated though. :wink:

So your network is like:

Main router -> mt300nV2 -> modem

The modem is actually works as a gateway.

You can bridge your modem and LAN port. You need to do this in luci -> network - interfaces
Find lan, the in interface find modem and select it. Disable DHCP. Save it.

Thanks for the quick reply!
Yes, that’s correct. A more detailed layout is this:

PCs and other devices <–wired and wireless connections–> Main Router <–ethernet cable–> MT300NV2 <–usb cable–> 4G LTE Modem

The PCs and other devices that connect to the main router are set up with static IPs, though the main router does have it’s DHCP server enabled for the occasional device that might connect and isn’t set up with a static address. The cable between the main router and the MT300NV2 is plugged into the main router’s WAN port, and the MT300NV2’s LAN port. The main router get’s it’s WAN IP from the MT300NV2, and is 192.168.8.xxx. The 4G model is set up as a new connection in the MT300NV2 as “tethered”. The 4G modem tethers the same as an Android phone, it identifies as a RNDIS device. The MT300NV2 gets a WAN IP address via DHCP from the 4G modem.

The reason I would like to bridge the MT300NV2 is to get rid of the extra NAT, with the PCs and other devices being behind two routers.

I want to keep the main router functioning normally for a couple of reasons. I have a wired gigabit network in the house, and would like to keep that up if possible. I also want to keep the routing functions in the main router because I use it’s QoS features to limit the bandwidth on some of my PCs. Being on a mobile network, I have to watch my data consumption and keep it within reasonable limits.

If possible I would like to have the MT300NV2 “transparent” so the 4G modem gives the WAN IP address straight to the main router, and performs no routing/NAT functions. I only need it to interface the USB tether to the ethernet cable.

I looked in LuCI, but wasn’t able to find what you suggested.

Just a quick note to say I was able to figure this out and got it working how I wanted. :slight_smile:
I went to the Network> Interfaces page in LuCI as instructed, then selected the ethernet port that I was using, checked the box to bridge “eth1” which is the virtual ethernet port associated with the USB tether, and disabled DHCP on this port. Once I saved, and rebooted the main router, the USB tethered hotspot gave an IP adderss to the main router, and running a tracert doesn’t show the MT300N-V2’s IP, it’s running “transparent” without NAT as I wanted. Nice!

One thing to note, is that I can no longer access the MT300N-V2 at it’s IP address (192.168.8.1), and it doesn’t respond when pinging it’s IP either. Maybe it’s because it’s in a different subnet, or possibly because it’s on the WAN side of the main router, but it’s not important. If I need to get into it again I’ll deal with it then, Worst case, I’ll have to reset it to defaults… lol

Since you wanted it to be transparent, then it is :stuck_out_tongue:
To access the interface again you will have to connect using a lan cable, and setting static ip on your computer to 192.168.8.2

For that reason i would recommend you do all the settings and stuff you need before, then finally do the transparent and set it and forget it.

That’s pretty much what I thought. I did set the static IP on one of the PCs on the main network to 192.168.8.xxx and still couldn’t ping it, but I’m guessing the main router is stopping the traffic from reaching it since it’s on the WAN port. I could probably set up a static route in the main router too allow access to it, but I like the “set and forget” ideal better. lol It’s quietly working doing exactly what I needed it to, I shouldn’t need to access the interface again, surely not on a regular basis.

These are neat little routers for sure though! I think I’ll pick up another just to play around with and learn more about OpenWRT.

I figure this to be a long shot since its been almost a year but its worth a try. I see where Keith got this working for his configuration and amazingly that is the very same config i am after. Only difference is my router is an asus 88u. I know next to nothing about networking configurations and it seems the more i research and read the more confused i become. Luckily i have stumbled across this post after several days of stumbling around tbe web trying to do just this. Am wondering if OP or someone else even could give detailed and precise directions for achieving this hopefully in just one attempt. Config is exactly the same as i am after but reason i am after it is for the ddns on main router for my home automation stuff to be able to reach remotely if need be. Any and all help would be greatly appreciated. Thank you