GL-MT300N-V2 vlan tagging on WAN

Hi, I need to use pppoe with tagged vlan to connect to my ISP. Is it possible on this router?

1 Like

I don’t have relevant test environment here, I don’t know whether 300n-v2 can do this or not, it depends on the driver.
But according to other users, 750S is ok

Hi,
750 creta is ok too?
This tag under luci then wan interface?
Thanks

I used AR750S and 300n-v2 to do a simulation experiment. It was OK on 300n-v2. I took AR750S as the main router and configured tag on the LAN,and then configure TAG on the WAN with 300n-v2 as the client. My configuration is as follows:

for ar750s

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd34:c4ef:09d4::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0.3'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.hostname='GL-AR750S-ff3'
network.lan.ipaddr='192.168.88.1'
network.wan=interface
network.wan.ifname='eth0.2'
network.wan.proto='dhcp'
network.wan.hostname='GL-AR750S-ff3'
network.wan.metric='10'
network.wan6=interface
network.wan6.ifname='eth0.2'
network.wan6.proto='dhcpv6'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='3'
network.@switch_vlan[0].ports='2t 3t 0t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='1 0t'
network.guest=interface
network.guest.ifname='guest'
network.guest.type='bridge'
network.guest.proto='static'
network.guest.ipaddr='192.168.9.1'
network.guest.netmask='255.255.255.0'
network.guest.ip6assign='60'

for 300N-V2

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fdfd:95fa:41d4::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0.1'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.hostname='GL-MT300N-V2-202'
network.lan.ipaddr='192.168.8.1'
network.wan=interface
network.wan.ifname='eth0.3'
network.wan.proto='dhcp'
network.wan.hostname='GL-MT300N-V2-202'
network.wan_dev=device
network.wan_dev.name='eth0.3'
network.wan_dev.macaddr='e4:95:6e:40:a2:02'
network.wan6=interface
network.wan6.ifname='eth0.3'
network.wan6.proto='dhcpv6'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='1 6t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='3'
network.@switch_vlan[1].ports='0t 6t'
network.guest=interface
network.guest.ifname='guest'
network.guest.type='bridge'
network.guest.proto='static'
network.guest.ipaddr='192.168.9.1'
network.guest.netmask='255.255.255.0'
network.guest.ip6assign='60'

I just tested the AR750 and it failed
I also tried to re-adjust the port, but it was the same result

Thanks for the response everyone. I am still unable to get this going.
Where is this config file that you are editing? I am editing /etc/config/network and the syntax is different.
I set the "option ifname ‘eth0.100’ but it reverts back to eth0.2.

Please provide your network config

Got the config to stick, I had to do it via the CLI and then also on the gui.

You can set up a VLAN in MORE SETTINGS ->Advanced->network->switch

Firstly apologies for raising this thread from the dead, but it exactly matches what I am trying to do.
Based on the screenshot from @luochongjun above, I installed Luci and configured this:

However, my MT300N-V2 never gets an IP with a cable plugged in the WAN port. Other devices in the home, using VLAN 20 work correctly, so I know it’s not a server issue.
And here’s the network config:

root@GL-MT300N-V2:~# cat network

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd09:523a:0c44::/48’

config interface ‘lan’
option type ‘bridge’
option ifname ‘eth0.1’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option hostname ‘GL-MT300N-V2-4ab’
option ipaddr ‘192.168.8.1’
option igmp_snooping ‘0’

config interface ‘wan’
option ifname ‘eth0.2’
option hostname ‘GL-MT300N-V2-4ab’
option metric ‘10’
option proto ‘dhcp’
option peerdns ‘1’

config interface ‘wan6’
option ifname ‘eth0.2’
option proto ‘dhcpv6’
option disabled ‘1’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘1 6t’

config switch_vlan
option device ‘switch0’
option ports ‘0t 6t’
option vlan ‘20’

config interface ‘guest’
option ifname ‘guest’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.9.1’
option netmask ‘255.255.255.0’
option ip6assign ‘60’

config device ‘wan_dev’
option name ‘eth0.2’
option macaddr ‘94:83:c4:00:44:ab’

config device ‘lan_dev’
option name ‘eth0.1’
option macaddr ‘94:83:c4:00:44:ac’

config interface ‘tethering’
option proto ‘dhcp’
option ifname ‘eth1’
option metric ‘30’
option disabled ‘0’

root@GL-MT300N-V2:~#

Cheers.

Thanks for the information. I will try to figure it out for more. Keep sharing such post.

myccpay.com

Wish people would come back and update once they have some answers. So what happened?

From my perspective, nothing. I never did get it to work.

The VID must be associated with ifName. For example, if the ISP requires the VID to be 100, the ifname must be eth0.100
This is really difficult for users and we are ready to add this feature to the UI.

2 Likes

Please add this feature, thank you.

1 Like