GL-MT300N-V2 Wi-Fi problem

Hello. I recently bought and configured a GL-MT300N-V2 and I’m unable to connect to wi-fi most of the time. The router simply rejects the wi-fi password and give an error of “Incorrect password” and then prompts me for the password (which doesn’t work). After unplugging the router from power and repowering it (usually multiple times) it eventually allows me to connect. But then if I test it again, the problem returns. This is a huge problem for a travel router! I’ve tried resetting the setting and reconfiguring it multiple times and the problem persists. I’ve tried connecting from different wireless devices with the same result. I also tried it in a different location (this was actually during a trip and I was unable to use it even after numerous resets) so it’s not an environmental issue. I’ve also tried various power supplies and the problem persists. Finally, I replaced the unit with a brand new one which did not fix the issue either.

To clarify, this is a custom wi-fi password that I set, not the default. If I reset the router to factory setting the default password works fine.

Has anyone experienced anything like this?

Thanks in advance for any help!

Password is not more than 63 characters and has no special characters?

Time syncronized?

Correct, password is not more than 63 characters and has no special characters.

I’m not aware of synching the time on the router. Are you referring to the router or the client? If you’re referring to the client, one of them is a cell phone so the time is automatically synched. If you were referring to the router, can you provide more information please? Also, if the problem is one of time synch for the router, that would likely be a problem for anyone using this as a travel router if it sits in a drawer until you actually take a trip…

Thank you for the ideas

Maybe you can just try change the encryption and channel?

I have the same unspecific problem when I am changing the AP password away from the default, but also before I do that the Mango behaves very unstable.
Are you using firmware 3.203?
I downgraded to and all these problems disappear.
Please share if that helps.

Try to select “802.11g” 20 MHz in the wifi settings on GL-MT300N-V2