GL-MT300N-V2 - Wireguard connection not working with most configs - despite them working on Android

Hi, I have a VPN Unlimited subscription and have been using their service via OpenVPN on my GL-MT300N-V2. All worked well. Still, as they offer WireGuard and I read it was the superior technology, I wanted to give it a spin.

I used the VPN Unlimited web management interface to create WireGuard profiles for their US Netflix, BBC iPlayer and two of their German access points and imported them (copying and pasting the content of the config files to the Mango’s web interface) to my little router.

Trying to connect, only one of the German configs works. The other three connections remain in the intermediate phase (yellow status dot and “Abort” button visible in the interface) and no data seems to be flowing.

Weirdly, when I imported the same configs to the official Android WG app via the 2D code, the connections work as far as I can tell.

As the Mango’s configuration interface does not give any details regarding WireGuard connection status, I am at a loss how to attempt to troubleshoot. Any ideas?

Is the VPN Unlimited’s WireGuard config include IPv6?
If yes, please remove the IPv6 content.
I show an example below, remove the highlight content.
wireguard_config_remove_ipv6

If no, could you please send a config via Direct Message to me, it will try it.

https://docs.gl-inet.com/en/3/app/wireguard/#wireguard-providers

Hi Leo, no, there was no IP v6 in there.

Weirdly though, the issue seems to have solved itself. I created a new device in my VPN management console, and the WireGuard configs I created for you all worked on my Mango. All good now, but no idea why…

Cheers.