GL-MT6000 (Flint 2) Multi-Wan

Just received my GL-MT6000 yesterday and got it configured - really happy with it so far.

  • Updated to firmware 4.5.3 upon initial configuration.
  • Connected to a local fiber provider who provides an optical network terminal with 4 WAN ports on it (ie, I can connect multiple routers to it and have multiple 1 Gbps connections - I’ve tested this with speedtest and each connection seems to have its own 1 Gbps cap on it)
  • I am configured to use Cloudflare encrypted DNS, with as a backup.
  • One port uses a static address, the second port uses a dynamic address (from the ONT)

I run Privoxy on the router, along with adblock (not the AdGuard Home subscription service, just the adblock package) - both are managed through Luci plugins (I’ve run openWRT for years, so am familiar with using that interface, but have done all the network configuration through the GL WebUI). I have tried disabling both of these services, but it doesn’t seem to make a difference.

What happens is that sometimes I connect, and sometimes my browser responds with a ‘tunnel failed’ (Chrome on Linux).

What I’d like to do is use load balancing to be able to use the two WAN ports so multiple devices can use up to a total of 2 Gbps - but I seem to be missing something that would have it work reliably.

Failover mode works flawlessly, but I’d really like to be able to double my effective speed. :slight_smile:

Hey :wave:

I am happy that you enjoy this device so much!

This is not really possible as the data streams are distributed. As a result, a client can still only achieve 1 Gbps with one data stream. However, if the software can cope with the packets coming in via different IPs and MACs, it could theoretically work - in reality this is not the case. Especially not with encrypted data such as HTTPs.

WAN bonding usually requires a remote station that supports this.

Thanks for the quick follow-up. I should clarify that I understand that it’s essentially only allowing a single device up to 1 Gbps output - that’s as fast as I need for a single device.

But if I have two devices that are doing high-bandwidth operations (like a big download on my PC and a big download on my PS5), I’d like the streams to be balanced between the two connections, which is what I understand this functionality is supposed to do. (ie, not looking for bonding, just distributing streams over the multiple connections)

Sorry I wasn’t clear about the intent. Since the LAN ports only are 1 Gbps ports, I do understand that no single device can use more than 1 Gbps of bandwidth. That’s perfectly fine. :slight_smile:

1 Like

No problem!

I would say mwan3 (the HA/Loadbalancer plugin used in OpenWrt and GLinet FW) should be able to do what you need.

Since I can’t test it, you should read the docs about it and just play around:

It might (!) be better to use luci for configure the WAN only then because I don’t know what other magic the GL GUI will do. :smile:

mwan3 is installed and enabled by default, afaik. So just some more config maybe.

Thanks! Yeah, that’s what I’ve done so far is enabled it in the GL webUI. Failover works really well (a slight delay in DNS lookups while it’s failing over). Was hoping it would be just a question of turning it on and then setting the values to 0 for the Repeater and Tethering load ratios (since those interfaces aren’t in use - I suspect that’s not necessary, though).

I’ve worked with other load balancers (reverse proxies, mostly - haproxy and a proprietary reverse web proxy from a company I used to work for), but the concepts are all the same - just the traffic direction is reversed (since this is a forward load balancer rather than a reverse load balancer).

It looks like the default multi-wan configuration uses GL’s multiwan rather than mwan3 (installed package is gl-sdk4-ui-multiwan - but I don’t see any other multiwan-related packages installed by default - I don’t see that mwan3 is installed by default).

According to the docs at Multi-WAN - GL.iNet Router Docs 4 - it looks like setting eth0 and eth1 to “1” and tethering and repeater to “0” is the right decision. The two ethernet interfaces are the same speed, so that would balance at a 1:1 ratio between the two interfaces.

I’m figuring this would be easier to configure if I can get it to work - and if there’s a bug that needs to be investigated, then I’m happy to experiment to determine what it is. :slight_smile:

Maybe it changed to „multiwan“ on the Flint2 because on the Flint1 it was mwan3 for sure - it causes much trouble. :smile:

Or maybe multiwan is just a mwan3 fork.
Maybe some GL staff could clarify it.

But you seem to be right. 1:1 should do the trick as the GUI says.

Yeah, hope someone from GL can clarify how this should be used. :slight_smile:

The package’s name is kmwan

If the other two interfaces are not connected, the ratio is invalid. Only the ratio of the connected interfaces takes effect

Thanks - so am I to understand that either (a) I should leave everything at “1”, or (b) that setting the disconnected interfaces to any value won’t matter because they’re not used?

In either case, how do I get this functionality to work properly? Or will that change address the issue?

That’s right.You can set the value of both to 1, so it will be the same probability when visiting different sites.However, for a site that has established a connection, it will not use another Ethernet port to establish a connection unless the Ethernet port that established the connection cannot provide the network.

Thanks for this info.

When I turn it on, I still am seeing my browser say that the tunnel could not be established - but it’s inconsistent. Same sort of thing with Discord - sometimes it stays connected, and sometimes it fails to connect.

How can I troubleshoot this to determine why it’s not working as expected?

You can try setting the Sensitivity to low or the time to 10s in Multi-WAN–Sensitivity Options.

That doesn’t seem to have helped - but I’m not sure how that would apply with load balancing (I can see how it would affect failover - but that’s working fine).

Sorry guys.
I have a question how to change IP in eth2? I am just making backup mobile data if the main wan is down.

The main router is

You can’t since the device you tether with is the one who decides about the IP range.
So indeed you should change your LAN network.

What happens if WAN is down and eth2 will work the LAN network with the same range

It simply won’t work.

Well, just unplug eth1 (WAN) and plug backup mobile data via USB (eth2)? Only manual to do? I can’t change my main LAN network range because some devices have static IP (CCTV, Pi, Qnap, etc)

This seems separate from my issue about using the Multi-Wan feature for load balancing. Perhaps you should start your own topic with your question to get it better visibility.

I don’t have an answer for my question here about how to effectively get the multi-wan feature working properly.

sorry, I don’t want a duplicate topic. so that reason my question here