GL-MT6000 slow 5GHz wifi (with up faster than down) and bouncing between 80Mhz and 160Mhz

Using my Macbook Pro (M1 Max, Sonoma 14.5):

  • connected directly to incoming fiber ~800Mbps down, ~800Mbps up
  • connected with ethernet to GL-MT6000 ~800Mbps down, ~800Mbps up

But when connected by 5GHz wifi (laptop ~1 Meter from router) I see:

  • ~60-300Mbps down, ~200-600Mbps up

Throughout the course of a single 5GHz wifi speedtest, both down and up speeds also vary a lot, sometimes starting quite slow (~20Mbps), but never getting above 350Mbps/650Mpbs.

Speeds in the same range for iPhone 14pro, though with less variation during test around 300Mbps download.

I've tried both 4.5.8 and 4.6.2 firmware on the GL-MT6000 with the same results. Also tried a few different Wi-Fi Security options (both WPA3-SAE and WPA2-PSK). Also bandwidth of 80MHz and 160MHz, both auto and manually choosing channels. All similar results.

Also noticed when in 160Mhz mode (including when forced to multiple DFS channels): bandwidth (as shown in Macbook detailed wifi menu) switching back and forth between 80 and 160Mhz seemingly randomly every 3-8 seconds.

Support asked if I was using repeater mode, but this router is a basic install and has never even had repeater mode turned on.

Am I looking at a hardware or a software issue here?

(edited to say 5GHz not 5G - oops!)

It's not 5G
It's 5GHz... They are different things.

Do you need to set the VLAN for your PPPoE authentication?

Oh man - yes, you're right, my bad! 5GHz wifi, not 5G cellular. (I'm not used to working with a router that could have cellular in the conversation - that's a super cool capability... that I'm not using here. :slight_smile: )

No PPPoE - router has direct WAN connection without authentication. Ethernet at the wall is raw internet connectivity. I do have guest network turned on, but that's the closest I have to VLAN so far.

I don't think macbook m1 support 160mhz Wi-Fi specifications for Apple devices – Apple Support (UK)

My work m1 does the same switching between 160 and 80mhz

Well now, there's an easy answer for the 160/80 switching! Thank you. So, I'm limited to 80MHz bandwidth, but still...

Back to the 300MHz down and 600MHz up, which is the real problem... based on everything I can find, the Macbook and iPhone should both be capable of higher speeds, and nothing says anything about down being slower than up. That said, I don't have a different router to compare against.

Would it make any sense that clients would only be able to use 40MHz down but 80MHz up?

I am having similiar issue as per stating here.

But not sure what kind of info needed to the community or steps can be taken.

Kindly let me know if you found any solutions.

what wifi mode are you using? ac/ax?

(re wifi mode, I've tried all the possible settings. currently, mac shows connection as ax.)

I tried a few more setups this evening:

In order to eliminate the macbook pro's wifi radio, I added the GL-MT3000 I purchased at the same time to the mix.

(laptop wifi off during all tests, using ookla's speedtest app for all speeds)

Laptop -> WAN = ~900mbps down, ~800mbps up

Laptop -> ethernet to GL-MT3000 -> WAN = ~900mbps down, ~800mbps up

Laptop -> ethernet to GL-MT6000 -> WAN = ~900mbps down, ~800mbps up

Laptop -> ethernet to GL-MT3000 -> ethernet to GL-MT6000 -> WAN = ~900mbps down, ~800mbps up

Laptop -> ethernet to GL-MT3000 -> 5GHz Wi-Fi (11a/n/ac/an/ax 160MHz, DFS channel) -> GL-MT6000 -> WAN = ~320Mbps down, ~580Mpbs up

Laptop -> ethernet to GL-MT3000 -> 5GHz Wi-Fi (11a/n/ac 80MHz, auto channel) -> GL-MT6000 -> WAN = ~300Mbps down, ~500Mpbs up

Laptop -> ethernet to GL-MT3000 -> 5GHz Wi-Fi (11ac/ax 80MHz, auto channel) -> GL-MT6000 -> WAN = ~300Mbps down, ~600Mpbs up

Laptop -> ethernet to GL-MT3000 -> 5GHz Wi-Fi (11a/n/ac 40MHz, auto channel) -> GL-MT6000 -> WAN = ~220Mbps down, ~170Mpbs up

I figured the two routers should be able to hit max speeds between each other, but regardless of wifi settings it was always about 2x as fast to upload as download (until I hit 40MHz in the last test)

And now... I'm completely and totally confused. I installed iperf3 on router and macbook, run router as server, and connect via client:

MacBook-Pro % iperf3 -c 192.168.8.1 --bidir
Connecting to host 192.168.8.1, port 5201
[  5] local 192.168.8.200 port 52905 connected to 192.168.8.1 port 5201
[  7] local 192.168.8.200 port 52906 connected to 192.168.8.1 port 5201
[ ID][Role] Interval           Transfer     Bitrate
[  5][TX-C]   0.00-1.01   sec  55.0 MBytes   459 Mbits/sec                  
[  7][RX-C]   0.00-1.01   sec  37.1 MBytes   310 Mbits/sec                  
[  5][TX-C]   1.01-2.01   sec  35.8 MBytes   300 Mbits/sec                  
[  7][RX-C]   1.01-2.01   sec  54.0 MBytes   453 Mbits/sec                  
[  5][TX-C]   2.01-3.01   sec  36.2 MBytes   304 Mbits/sec                  
[  7][RX-C]   2.01-3.01   sec  59.5 MBytes   499 Mbits/sec                  
[  5][TX-C]   3.01-4.00   sec  35.4 MBytes   298 Mbits/sec                  
[  7][RX-C]   3.01-4.00   sec  56.2 MBytes   474 Mbits/sec                  
[  5][TX-C]   4.00-5.00   sec  37.0 MBytes   310 Mbits/sec                  
[  7][RX-C]   4.00-5.00   sec  54.2 MBytes   455 Mbits/sec                  
[  5][TX-C]   5.00-6.00   sec  35.9 MBytes   300 Mbits/sec                  
[  7][RX-C]   5.00-6.00   sec  54.0 MBytes   452 Mbits/sec                  
[  5][TX-C]   6.00-7.00   sec  39.4 MBytes   331 Mbits/sec                  
[  7][RX-C]   6.00-7.00   sec  59.4 MBytes   500 Mbits/sec                  
[  5][TX-C]   7.00-8.00   sec  37.1 MBytes   311 Mbits/sec                  
[  7][RX-C]   7.00-8.00   sec  57.5 MBytes   481 Mbits/sec                  
[  5][TX-C]   8.00-9.00   sec  36.9 MBytes   309 Mbits/sec                  
[  7][RX-C]   8.00-9.00   sec  55.1 MBytes   462 Mbits/sec                  
[  5][TX-C]   9.00-10.00  sec  37.6 MBytes   315 Mbits/sec                  
[  7][RX-C]   9.00-10.00  sec  57.8 MBytes   484 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID][Role] Interval           Transfer     Bitrate         Retr
[  5][TX-C]   0.00-10.00  sec   386 MBytes   324 Mbits/sec                  sender
[  5][TX-C]   0.00-10.03  sec   384 MBytes   321 Mbits/sec                  receiver
[  7][RX-C]   0.00-10.00  sec   548 MBytes   460 Mbits/sec    0             sender
[  7][RX-C]   0.00-10.03  sec   545 MBytes   456 Mbits/sec                  receiver

iperf Done.

So... now its bouncing around, where ookla speedtest shows consistent 2x Tx vs Rx, this shows mostly Rx faster (but not the first round)...
I haven't had coffee this morning - what am I missing here? Is it possible internet and only internet traffic downloads more slowly only when connected via wifi?

(edited to show bidir and because my first try I actually had an ethernet cable connected)