GL-MV1000 "BRUME" speed problem


I have a new Brume set up, but the internet (WAN) speed drops. I have a 500mb/s speed internet ( NOS Madeira ) , modem gives the same speed, when I connect my pc directly.
Now I connected Brume, few days I got the same speed, but now its only 200-250mb/s speed.
Same problem is after factory reset.

i’ve tried with my precious routers (ER-X and USG from Unifi) and no speed problems.

Wierd, because Unifi routers specs are not even close to brume power.

Edit: I also tried previous firmware, same issue, max 260-270. First it bursts to 350 and then drops down to 260-270.


How are you doing the speed test, loaded or unloaded. For a loaded test I have all my devices on and downloading stuff from the internet and test through Unloaded use Bufferbloat and Internet Speed Test - Waveform and have only one computer connected with background process off. Most ISP will give you a throttle boost for 10-20 sec up to your max speed and then throttle down until more bandwidth is available.

No traffic, only my pc without local network. I’ve tested with and
Point is that in idle mode with my pc and unifi routers the speed is ok, only problem is with Brume with default configuration.

So what is the Speed of the ER-X and USG after a few days. Also what Firmware are you using?

Im using fw 3.215 as the latest one, also tried with 3.212

USG was running as my previous setup ( USG+Unifi AP’s+ NUC for Unifi controller+AGH), my old router.
Now I have Brume ( VPN+AGH) + Pepwave One AX

Was AdGuardHome running on the GL-MV1000 during testing? If so, can you disable it and rerun the tests?

I do not work for and I am not directly associated with GL.iNet

after reset, AGH is disabled by default. So, this is not the case right now. I already tried enabled/disabled and no differences.

1 Like

Can you check in the web panel->client, do you have realtime data statistics enabled?

If yes pls disable it.

As I said, with default settings after factory reset, no “realtime data statistics enabled” :slight_smile:

I just tested mine in HK, and here is firmware version and speed test for your info.

1 Like

You have 1gb/s speed?:slight_smile:

Yes, my broadband is Gigabit.

So you have the same problem - your speed should be around 950mb/s+, not 750mb/s
It means that Brume can’t handle speed like that…

Are you doing loaded or unloaded speed test.
Try with a unloaded speed test with Bufferbloat and Internet Speed Test - Waveform
Loaded speed test use

BRUME :Bufferbloat and Internet Speed Test - Waveform 309mb

USG: Bufferbloat and Internet Speed Test - Waveform 453mb

So waveform shows that the USG has high latency under load and the Brume has much lower latency under load. The majority of the the time you get a 100Mbps with a burst up to 421.08mbps.(from data provided)

You have 31 minutes between each speedtest in the early afternoon so I would call that a busy time for most ISP(Business day is concluding and such)
If its possible I would try for a 12-3am speedtests(my experience were i got sustained speeds at or above what was promised by ISP.) Make sure you have one computer background services turned off wired using the network for Waveform.

Could be QOS on the routers needs some changes or SQM use.

The Brume is running the best speed at the lowest latency.
:gl_emoji_dizzy:I do not work for and I am not directly associated with GL.iNet :gl_emoji_shacking:

I’ve made so many test, most important that tests are made at short intervals. That was just a sampler:)

Now I got another problem - over night my AGH “port forward for localhost solution” stopped working.
DNS don’t resolve.
Do you know the best solution so that AGH may show every user, not all in the same “localhost”?:slight_smile:

I’ve tried to find better solution.

DNS stopped because it lost connection with the upstream DNS servers and can’t resolve local host.

Easiest way for adguardhome to show every user is have it do DHCP(not recommended because it does not to do WiFi well) or be on a separate device.

Local Host is the proxy for adguard home (Part of DNSmasq), so it does not show MAC addresses or ips of computers on LAN

But why did it lost connection with upstream DNS server?
I’ve tried several different upstream servers ( I used nextdns) and it worked over 2 months.

I already used a NUC for AGH and Unifi Controller with USG, but I purchased the Brume, so that I don’t have to use NUC for AGH and I replaced Unifi to Pepwave.

If I can’t get the AGH to work with Brume, then it’s useless - I need to see every user, because I have children to block certain applications.

Right now I’m testing both NextDNS and AdGuard DNS, and i’m not satisfied.

edit: seems that upstream DNS problem was only with DoH NexttDNS , NextDNS dns ip worked, also google dns.
Now using Adguard DNS and its working.
I don’t want to send my dns queries to google etc:)

So: BRUME lives again! :slight_smile:

Are you using the correct adguard home settings page? Usually is the default gateway with :3000 after it. If you are using DoH or DoT don’t forget to bootstrap the DNS servers with correct IPs.