GL-MV1000 DNS query refused after stop OpenVPN client

Hi Glinet,
I bought a GL-MV1000 and I tried to use OpenVPN client to connect 3rd party VPN provider. It works good, however, when I stop OpenVPN client and the Windows client cannot browse any websites any more. I tried to use nslookup utility in windows command line and it received Query refused from GL-MV1000. Until I reboot GL-MV1000 and the windows client can browse web sites again.

Have you enabled Internet Kill Switch ?

No, Internet Kill switch is disabled.

What do you have under MORE SETTINGS, Custom DNS Server ?
Do you have AdguardHome enabled ?

Only “DNS Rebinding Attack Protection” is enabled.
ADBlock is disabled.

On the first page after login; INTERNET, what is in the DNS Server field ?

The DNS server filed is my up stream router’s IP address.
I tried to revert firmware to factory default and set OpenVPN client only. And then I tried to connect and disconnect VPN and then DNS query was working normally. Although I don’t know what is the root cause, at least it is working now.

1 Like