GL-MV1000 - PPPoE not working after update to 3.203

Hi There,

I upgraded a GL-MV1000 from 3.105 to 3.203 (with reset config) and with the last one I`m not being able to connect through PPPoE.

Here are the messages it shows in loop while trying to connect:

pppd 2.4.7 started by root, uid 0
PPP session is 1
Connected to e4:81:84:57:f1:63 via interface wan
Renamed interface ppp0 to pppoe-wan
Using interface pppoe-wan
Connect: pppoe-wan <–> wan

Connect time 0.0 minutes.
Sent 0 bytes, received 0 bytes.
Modem hangup
Connection terminated.
Sent PADT
Exit.

Username and password is the same as before in 3.105.
To confirm it is not a configuration problem I went back to 3.105 and now I can connect normally.

Is anyone else experiencing the same problem?

Regards,

edit:
I found something unusual after updating to 3.203:
The Advanced menu is not available:

msedge_n6lyukVmBT
I tried to refresh the repository but it stays with the same message. That does not happen with 3.105.

PS: I updated to 3.203 manually (GL.iNet download center) and automatically, so I`m pretty sure the problem is not the firmware file.

So the problem is that 3.203 breaks your pppoe connection.

Because it has no Internet, you will not be able to install Luci, which is not installed by default in 3.203.

I will call for developer to check the pppoe problem.

Hi stedile-jeferson:
I test that the pppoe is ok.


image

I’ll check it in detail,and check if there are any specific occasions when this happens.

Ok thanks!

Let me know if you need more info. If there is
any kind of log that can help you track the problem just let me know how I can get it.

Thanks, I can confirm that.
I reinstalled 3.203 and then I configured a Tethering USB connection using my mobile phone and after that Luci was installed successfully.
Unfortunately Luci installation didn`t fix the PPPoE problem :frowning:

Brume-w all working good, pppoe work, firmware v. 3.203.

Not sure if this helps, but I did a new test:

1- installed 3.203, PPPoE still failed
2- turned on the option IPv6 in More Settings/IPv6 (with default settings)
3- booooomm… PPPoE started working immediately
4-restarted the router with IPv6 enabled, still working
5- disabled IPv6 and restarted the router… :frowning: PPPoE didn`t connect again
6- enabled IPv6 again and PPPoE started working again

So… it looks like it has something to do with the IPv6 configuration.

1 Like

Do you have special config like VPN or something else?

No, I don’t have.
In fact to make sure it was not a config problem before I upgraded I reverted the firmware (in Luci). Also during the upgrade process I chose to not keep the settings.
The only configs I have apart from the default one are PPPoE username/password and now the IPv6 enabled (with standard options, I just slided it to right and confirmed).

Hi stedile-jefferson:

1, You can remove options ‘lock’ in “/etc/ppp/options”,then test whether PPPOE work?

2,Another case:PPPOE-server configuration Requirements that the connected device must be enabled with IPV6.
By default,IPV6 is enabled in 3.105,and is disabled in 3.203.

Could you determine which software is used to build your PPPOE-server?And how is it configured?

Hi lizh,

  1. where is that option in Luci?

Unfortunately I dont have that information. The ISP is Vivo (a well known brazilian ISP) but I dont have access to this kind of information.

There is no corresponding option with LUCI. You need to log in to the router and modify ‘“/etc/ppp/options’.

Hi stedile-jefferson:

Is pppoe issues resolved? I found a problem. If it’s convenient for you, I’ll send you a firmware test.

Hi lizh,

It is solved. I just need to remember to enable ipv6 just after the firmware is updated (before configuring pppoe), after that all works fine.

Anyway if you want me to try the new firmware, send me it and I will do the test.

Regards

Thankyou very much!
In the near future, we will give 3.211 a beta release(It will use pppoe normally, even if ipv6 is not enabled).