GL-MV1000 VPN policy

was there ever a fix for the VPN policy not working on the brume? specifically excluding a MAC address from using the VPN? when I set up vpn policy to exclude a certain wireless device’s MAC address, that device is unable to use the internet, while all the devices still using the vpn work just fine.

I know 3.2 was supposed to fix the vpn policy issue but brume hasnt recieved an offical update yet. I remember reading some threads about it but I cant find them now.

I am using a GL-MT1300 as an access point for the GL-MV1000.
my VPN set up is mullvad on wireguard.
my GL-MT1300 is running 3.301-0402
my GL-MV1000 is running 3.203-0430 but I had the same problem on 3.105

3.203-0430 still does not work on mac address based policy?

I have it working here on MV1000 3.203 with 3 MAC excluded from VPN.

just tried it again with two different devices. as soon as I exclude a MAC address from vpn that device is not able to load web pages. I can see that the devices are still connected to the routers, I can even access the router from the devices but no web pages. I also tried rebooting all routers and devices after making changes, makes no difference. confirmed that brume is on 3.204-0430

okay so I did a fresh install of 3.203-0430 and vpn policy is working now.

I can’t seem to find the 3.203-0430 image on the download page.
That’s all i can see on the download page, i would really appreciate if you can help with a link to download the image.

Just use 0701.img as the firmware

I’ve installed the 0701 image but the policy is still not working.
my use case is that i only want to allow certain domains like pass through the VPN.
Below is a screenshot of the settings

I use GL-Inet MV1000 with OpenWrt 19.07.7 r11306-c4a6851c72

What does a fresh install means? Is it installing via uBoot?
I would really appreciate any help.

1 Like

If you want clear installation, better use uBoot, and then make new config

Installed 0701 using uBoot, still no headway… Without VPN Policy all traffic goes through VPN - I want only selected domains to pass through VPN.

Pls tick the option “Use vpn for all process on the router” and check

Done - still the same.

Is there nothing I can do from LUCI web interface?