GL-MV1000W with active USB-hub on the USB 2.0 port

Hello everybody,

I am using the GL-MV1000W and have tested some USB hubs with active power supply on the USB 2.0 port. Unfortunately none is recognized by the MV1000 / or a connected USB stick or Alfa AWUS036ACS on the USB hub is also not recognized. Is there already a possibility / package that enables the MV1000 to recognize the USB hub?

The USB 2.0 port on the MV1000W works fine on its own, without a USB hub.

I am currently using the 3.203_beta3 release

Thanks and best regards from Germany


Can you get the system log?

ssh to the router and use “logread” and “dmesg” to get the log.

You can also get the log in luci

1 Like

I also had this problem a while ago trying to use an Alfa AWUS036ACS wifi dongle via a hub. The dongle works fine when attached directly, but doesn’t work when attached via a hub.

It’s a pretty big problem for me since I’m using the MV1000 and don’t have built in wifi. So until I figure out a workaround, I can’t for example hook up an external hard drive to the MV1000.

I’ll come back and post when I can get a spare hub and test it again so I can capture the logs.

Maybe it is not enough power supplied.

Use a Hub that has separate power.

1 Like

I’m having this same issue. For some reason, the wifi dongle is being recognized but the negotiation decides to not provide it with any power. I’m also using a powered hub. I’ve tried 3 of them actually.

1 Like

I plugged in a TP-Link UE330 USB 3.0 non-powered hub/ethernet adapter into the USB 2.0 Type A port on my GL-MV1000W. The router was able to recognize, mount and share a USB flash drive.

All of the hubs I’ve plugged in are recognized. In fact, I have tried plugging in my iPhone, a flash drive, even an external 2.5” spinning HDD. They were all recognized as well. The only 2 things that are not recognized for some reason are an RTL8812AU and an RTL8821CU. Kind of doesn’t make any sense.

In another thread, you stated:

My problem is that even the USB-A port doesn’t recognize anything connected to a hub on it either.

When I plugged in an RTL8821AU wifi adapter into the non-powered hub, the router did recognize it and it showed up on both the GL GUI and LuCI GUI. However, the wifi did not work which may be due to only 2.5W output from the USB 2.0 Type A port.

1 Like

Yes. That is my experience as well. The Hub gets recognized and everything I’ve plugged into the hub gets recognized as well except for the wifi dongles. Surely, the dongles don’t pull as much power as a hard drive which worked without issues. It also doesn’t matter if it’s a powered hub or not; Wifi dongles don’t get recognized.

This situation is a dead-end and a lost cause. I also tried a powered hub without success.

The built-in ethernet port in my TP-Link UE330 hub/ethernet adapter does not work either.